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About this tutorial 

In this tutorial, you will view spreadsheets, create a selection set, and work with COGO 
controls. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 

For this tutorial, you will use the project file Using Spreadsheets.vce. GNSS, total station, 
and level data has already been imported into the project, and GNSS baselines have 
been processed. 

Note: The downloaded UsingSpreadsheets folder contains this PDF file and the Using 
Spreadsheets.vce project file.  

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\UsingSpreadsheets\Using Spreadsheets.vce and 
click Open. 

The project opens in the Survey Office window. 

  

The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 
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You are now ready to explore some of Survey Office’s features. 

Step 2. View spreadsheets 

In this step, you will view two spreadsheets available in Survey Office: 

 Occupation Spreadsheet 

 Point Spreadsheet 

You can customize what is displayed in spreadsheets and how it is displayed, as shown 
in the following steps.  

1. In the Quick Access toolbar (located at the top of the SO window), select Project 
Settings. 

2. In the navigation (left) pane in the Project Settings dialog, select View > Points 
Spreadsheet. 

A list of the names of columns available for the Points spreadsheet display in the 
table. Each column name is followed by an indicator of whether the column should 
be included in the spreadsheet. 

  

You can click on any of the Show/Hide indicators to change the selection. 

In the navigation (left) pane in the Project Settings dialog, you can select other 
spreadsheets in the View menu to view and change the Show/Hide column settings 
for them as well. For this tutorial, there is no need to make changes. 

3. Click Cancel to close the Project Settings dialog. 

Next you will see how to customize a spreadsheet by sorting the rows in it. 

4. In the Survey Office ribbon, select Home > Data > Points.  

The Point Spreadsheet displays. 
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You can sort the rows in the spreadsheet based on the column heading you select. 
By default, the rows are sorted in ascending alphabetical order based on the Point 
ID. 

5. Click the Elevation column heading to sort the rows based on the ascending and 
descending elevation of the points. 

Note that the Sort icon indicates whether the sort is in ascending (the arrow points 
up) or descending (the arrow points down) order. 

   

You can filter the displayed rows by clicking the filter icon for a column and selecting 
the appropriate filter. The default filter is All. 

6. Click the Feature Code filter icon  and select NonBlanks in the context menu. 

  

Only points with feature codes assigned are displayed in the spreadsheet. 
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You can further customize your spreadsheet as follows: 

 Resize the width of any column by placing the cursor on the column border in 
the heading row and dragging it left or right. 

 Move a column to a new location using "drag-and-drop." 

 Move the spreadsheet tab to a new location. Simply click on the tab label and 
drag it downward off the tab bar before releasing. Then select a location option 
in the context menu. 

Try right-clicking the tab label and selecting New Vertical Tab Group to display 
the tab vertically in the window. 

Use the same procedure to move the tab back. 

Any content displayed in blue in the spreadsheet can be edited. For example, you 
can type in a new Point ID, or you can edit a Feature Code directly in the column or 

by clicking the browse button  to display the Feature Code Editor dialog. 

  

You can copy rows from a spreadsheet into a Microsoft Excel spreadsheet. Just 
select the rows you want to copy, press Ctrl+C to copy, select a cell in the Excel 
spreadsheet, and press Ctrl+V to paste. Although the header row cannot be 
selected, it is always copied and pasted into the spreadsheet along with the rows 
you select. 

You can display the Properties pane for any point by selecting the row, right-
clicking, and selecting Properties in the context menu. 
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Custom filters allow you to select the criteria for filtering data displayed in a 
spreadsheet. In the following example, you will select to view only the points that 
did not use the R8 GNSS/SPS88x Internal antenna type. 

7. Select Home > Data > Occupation.  

The Occupation Spreadsheet displays. 

  

8. Click the Ant. Type filter icon  and select Custom in the context menu. 

  

The Custom Filter dialog displays. 

  

9. In the Ant. Type drop-down list, select Does not equal to. 

10. In the second (operand) drop-down list, select R8 GNSS/SPS88x Internal. Then click 
OK. 

The spreadsheet refreshes based on your custom filter. Only points that did not use 
the R8 GNSS/SPS88x Internal antenna type display. 
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You are done looking at spreadsheets. Next, you will take a look at how to create and 
use selection sets. 

Step 3. Create a selection set 

If you need to select the same objects over and over, it can be frustrating to manually 
make your selections and it is easy to make mistakes. Instead, you can use the Selection 
Explorer to create reusable selection sets. 

1. Click on the Plan View and use your mouse wheel to zoom in. Press the mouse 
wheel and move the mouse to center the points as shown here. 

  

2. Select Home > Selection > Selection Explorer to display the Selection Explorer. 

The Selection Explorer includes a Selection Sets list (1 below) that includes all of the 
selection sets in your project. Located beneath it is a Selection Palette list (2 below) 
that includes all of the member objects included in the currently selected selection 
set(s). If <Selection Snapshot> is selected in the Selection Sets list, whatever is 
selected in the graphic view is included in the Selection Palette list, allowing you to 
save your selection as a new selection set or add it to an existing selection set. Since 
you have not yet made a selection, nothing is displaying in the Selection Palette 
with <Selection Snapshot> selected. The tool bar includes icons for commands you 
can use to create and modify selection sets as necessary. 
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Selection Sets tool bar: 

 

1 - Remove selection sets without deleting contained objects - Click this icon to 
remove any selected selection set(s) from the project without removing their 
member objects. 

2 - Add the selection to selection sets - Click this icon to display the Add To dialog, 
which allows you to specify selection sets to which you want to add any currently 
selected objects in the project. 

3 - Subtract the selection from selection sets - Click this icon to display the Subtract 
From dialog, which allows you to specify selection sets from which you want to 
remove any currently selected objects in the project. 

Selection Palette tool bar: 

 

1 - Create a selection set (save entire selection palette) - Click this icon to display 
the Save As dialog, which allows you to create a new selection set containing all of 
the objects displayed in the Selection Palette list. 

2 - Refresh the selection snapshot - Click this icon, if active, to refresh the 
<Selection Snapshot> set displayed in the the Selection Palette list. 

3 - Add objects to the selection palette - Click this icon to add to the Selection 
Palette list any selected objects in the project. 



 

 

 www.spectrageospatial.com Page 9  
 

4 - Subtract objects from the selection palette - Click this icon to remove from the 
Selection Palette list any selected objects in the project. 

3. In the Plan View, use your cursor to draw a selection box around the group of 
objects you want to include in your selection set, as shown here. 

  

Selection rules are as follows: 

 Click and drag from left to right to select only the objects that are included in 
the selection box (for example, points). 

 Click and drag from right to left to select the objects that are included in the 
selection box (for example, points) along with any objects that cross the 
selection box (for example, observations, baselines, vectors, and mean angles). 

 Use Ctrl + click or Ctrl + drag to add a single object or multiple objects to the 
selection set.  

 Use Shift + Ctrl + click or Shift + Ctrl + drag to remove a single object or multiple 
objects from the selection set.  

Your selections display in the Selection Explorer in the <Selection Snapshot> 
objects list. 
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4. On the Selection Explorer toolbar, click the Create a selection set (save entire 
selection palette) icon to display the Save Selection Set As dialog 

5. In the Save <Selection Snapshot> As dialog, enter a name for your selection set: 
Tutorial Selection. Then click OK 

 . 

Your new selection set is added to the Selection Sets list. To view the objects 
contained in your selection set, simply select the set in the Selection Sets list. 
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You can view properties for any object in the selection set by selecting it in the list, 
right-clicking, and selecting Properties in the context menu. To select multiple 
objects in the list, use Ctrl + click or Shift + click. Selecting multiple objects can be 
particularly useful if you want to specify a property (for example, a feature code) for 
all of them at the same time. 

To select the objects in multiple selection sets, press the Ctrl key and make your 
selections in the Selection Sets list. 

6. Close the Selection Explorer pane. 

Additional notes:  

 Selection sets are created automatically when you import data containing scan 
station labels. See "Work with Scan Station Labels and Selection Sets" in the SO Help 
for more information. 

 The selection sets you create, and those created from some types of imported files, 
also appear in the View Filter Manager. They can be used as a starting point in 
creating view filters. See "View Filter Manager Options" in the SO Help for more 
information.. 

You are done working with selection sets. Next, you will take a look at some useful 
COGO controls. 

Step 4. Work with COGO controls 

COGO (COordinate GeOmetry) controls are the boxes in various commands that help 
you calculate angles, bearings, coordinates, distances, elevations, and offsets in your 
project. They enable you to enter data in a variety of ways, including: 

 Typing values and point IDs in the box 
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 Picking points in graphic views 

 Right-clicking in graphic views and selecting additional snap and COGO options from 
the context menu 

COGO controls provide this flexibility so that you have many ways in which you can 
enter data within a single command, rather than forcing you to work through multiple 
commands. 

COGO snap commands use geometric calculations to help you specify coordinates more 
easily and accurately. Snap commands can calculate a snap point by using existing 
geometry or by using parameters that you enter. Snap commands are available any time 
you are required to enter a coordinate. Simply right-click to see the options. 

In the following procedure, you will create four new points in your project (1, 2, 6, and 
7) using the various COGO controls and snap commands available in Survey Office. 
However, before you create new points, you should verify that snap mode options are 
set correctly. 

1. Click the Snap button on the status bar in the bottom of the Survey Office window. 

  

The Running Snap Mode Options dialog displays. 

  

This dialog allows you to specify snap mode options. The description for each option 
is displayed in the dialog. 

In this procedure you will be using snap commands to select points. To ensure you 
are selecting a point and not a coordinate near a point, you will deselect the Free 
mode (if it is selected).  

  

2. In the Running Snap Mode Options dialog, do the following: 

a. Verify the Point mode check box is checked. 

b. Uncheck the Free mode check box. 

c. Click OK. 
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3. Create point 1 as follows: 

a. In the SO ribbon, select CAD > Points > Create Point. 

The Create Point pane displays. 

  

b. Ensure the Point ID field displays 1, the Feature code field is blank, and the 
Coordinate type field displays Grid. 

c. Right-click in the Northing field and select Bearing Distance. 

  

The Bearing Distance pane displays. These controls enable you to calculate a 
point based on a beginning point, a bearing, and a distance. The zero (0) bearing 
is north and bearings are measured clockwise. No elevation (Z value) is set using 
this option. 
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Note: For this tutorial, you will be entering bearing values. However, if you prefer, 
you can enter azimuth values. In the following steps, instead of entering a bearing 
value of S37 44 56E you could enter a north azimuth value of 142 15 04 (142° 15' 
04"). 

d. Click in the Reference Point field, then click on point 5 in the Plan View. 

The coordinate for point 5 displays in the field. As an alternative, you could just 
type 5 in the field. 

e. In the Bearing field, enter s37 44 56e. 

There is no need to enter capital letters for South and East. 

f. In the Distance field, enter 290.91sft.  

Note that the value specifies the distance unit sft (US survey foot). This is 
required if a value you want to enter uses a distance unit that is different than 
the unit specified in the Project Settings dialog (meters). 

g. Click OK. 

The coordinates for the new point 1 display in the Create Point pane. 

  

There is no need to enter an Elevation or Height value. 

h. Click the Add button. 

The new point 1 displays in the Plan View. The Create Point pane has been 
cleared so you can create another new point. 

  

4. Create point 2 as follows: 

a. In the Create Point pane, ensure the Point ID field displays 2. 
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b. Right-click in the Northing field and select Bearing Distance. 

The Bearing Distance pane displays. 

c. In the Reference Point field, enter 3. 

The point ID automatically converts to a coordinate. 

d. In the Bearing field, enter n18 05 08e. 

e. In the Distance field, enter 322.91sft.  

  

f. Click OK. 

The coordinates for the new point 2 display in the Create Point pane. 

g. Click the Add button. 

The new point 2 is displayed in the Plan View. 

  

You are now ready to create a new point 6, which will be located midway between 
points 1 and 2. 

5. Create point 6 as follows: 

a. In the Create Point pane, enter 6 in the Point ID field. 

b. Right-click in the Northing field and select Middle of Point to Point. 
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The Middle of Point to Point pane displays. These controls allow you to 
calculate a location midway between two points. 

  

c. In the From point field, enter 1. 

d. In the To point field, enter 2.  

e. Click OK. 

The coordinates for the new point 6 display in the Create Point pane. 

f. Click the Add button. 

The new point 6 is displayed in the Plan View. 

  

Next you will create a new point 7. This point will be located in line with points 3 
and 6, 5° south of the 5-to-fsi line, as shown in the following image. 
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6. Create point 7 as follows: 

a. In the Create Point pane, ensure 7 displays in the Point ID field. 

b. Right-click in the Northing field and select Bearing Bearing. 

The Bearing Bearing pane displays. These controls allow you to calculate the 
intersection of two bearings defined by a first point and second point. 

  

c. Click in the Reference point 1 field and then select point 5 in the Plan View. 

The cursor automatically moves to the Bearing 1 field. 

d. Select point fsi in the Plan View to define the bearing. 

The cursor automatically moves to the Reference point 2 field. 

e. Click back in the Bearing 1 field and type +5 after the bearing value. 

This adds 5º to the bearing as soon as you click in a different field. 

    

f. Click in the Reference point 2 field and then select point 3 in the Plan View. 
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The cursor automatically moves to the Bearing 2 field. 

g. Select point 6 in the Plan View. 

The coordinates for the new point 7 display in the Create Point pane. 

  

h. Click the Add button. 

The new point 7 displays in the Plan View. 

  

You can now reselect the Free snap mode option in case you need it turned on for 
other projects. 

You are done working with COGO controls. Feel free at this time to continue exploring 
the Survey Office software. Press F1 at any time to view the associated online Help. 

This completes the tutorial. 
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