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Importing Total Station Data 
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About this tutorial 

In this tutorial, you will import total station traverse data into a project that already 
contains GNSS and level data. Then you will delete an incorrect station setup, change an 
incorrectly specified prism type for some observations, disable outlying observations, 
and adjust the traverse. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 

For this tutorial, you will use the project file Importing Total Station Data.vce. GNSS and 
digital level data has already been imported into the project, and GNSS baselines have 
been processed. 

Note: The downloaded ImportingTotalStationData folder contains this PDF file, a Data 
folder, and the Importing Total Station Data.vce project file. You will import data from 
the Data folder later in this tutorial. 

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\ImportingTotalStationData\Importing Total 
Station Data.vce and click Open. 

The project opens in the Survey Office window. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 

You are now ready to import total station data into your project. 

Step 2. Select project settings 

For this tutorial, you will import a data file containing traverse data collected with a 
total station. The traverse was adjusted in the field software prior to import. Because of 
the accuracy of the equipment used to collect data for this survey, you will increase the 
default tolerance specified for mean angles in your project before you import the data. 
You will also specify zero-tolerance for imported duplicate points so that you will be 
prompted to select which duplicate points to merge on import.  

1. In the Quick Access Toolbar (located at the top of the Survey Office window), select 
Project Settings to display the Project Settings dialog. 

2. To specify zero tolerance for imported duplicate points, do the following: 

a. In the Project Settings dialog, select Computations > Point Tolerances in the 
navigation pane. 

b. In the Merge On Import section, select By Custom Tolerance in the Merge 
options drop-down list. 

You will leave the default custom tolerance values of 0.00 m. This will cause the 
Merge Points dialog to display when you import the total station data, allowing 
you to select whether or not to merge each duplicate point. If you had not 
changed this setting for this data set, the default values used would cause the 
duplicate points to be merged automatically on import, without displaying the 
Merge Points dialog. 

  

3. To increase the default tolerance specified for mean angles, do the following: 
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a. In the Project Settings dialog, select Computations > Mean Angles in the 
navigation pane. 

b. In the Tolerance of Mean Angles section, enter: 
- 0°00'05" in the Horizontal angle field  
- 0°00'08" in the Vertical angle field 

  

4. Click OK. 

You are now ready to import the total station data. 

Step 3. Import the total station data 

1. Select Home > Data Exchange > Import. 

The Import pane displays in the right side of the Survey Office window. 

2. In the Import pane, click the Browse button . 

3. In the Browse for Folder dialog, browse to ..\ImportingTotalStationData\Data and 
click OK. 

The Data folder contains the JXL data file that you will import into the project. 

The content of the Data folder displays in the Select File(s) list in the Import pane. 

  

4. In the Select File(s) list, select filloop.jxl and click the Import button. 

Since the software detects a difference between the coordinate system specified in 
the project and the coordinate system specified in the imported file, the Project 
Coordinate System message dialog displays. 



 

 

 www.spectrageospatial.com Page 5  
 

5. In the Project Coordinate System message dialog, click the Details button. 

The Coordinate System Comparison Report displays in a browser window where 
project values and imported values are shown side-by-side. Differences are 
highlighted. For this tutorial, you will use the project values. 

 

 

6. Close the report and select the Keep the existing project definition option in the 
Project Coordinate System message dialog. Then click OK. 

The Merge Points dialog displays showing the imported point IDs that are duplicates 
of point IDs already existing in the project. For this import, you will merge each of 
the duplicate points. 

7. In the Merge Points dialog, check each of the Merge check boxes and click Import. 

  

Because the duplicate points will be merged during import, the traverse adjustment 
performed in the field will be removed.  
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Note: Points that are adjusted by a traverse adjustment are in a "fixed" state. They 
are not re-computed by a change to the coordinates of the starting or ending points 
unless you perform a least-squares network adjustment (select Survey > Network > 
Adjust Network). Although, in this case, the traverse adjustment was removed 
when the duplicate points were merged, you can re-adjust the traverse after the 
import is complete. 

After import, numerous error flags display in the Plan View. You can view the 
messages associated with each of these error flags in the Flags Pane. 

 

 

8. In the SO ribbon, select Home > View > Flags Pane. 

9. Most of the error flags are due to exceeded tolerances. You will deal with these 
later in the tutorial. However, there is one error that you will correct now: Station 
Setup Plus (?) - Setup failed to compute. 
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The error message indicates that the station setup is incomplete. (Note that no 
backsight point IDs are included in parenthesis following Station Setup Plus.) For this 
survey, the surveyors in the field mistakenly started by using Station Setup Plus for 
the setup type, which is represented by filter (S1). Instead, they should have started 
with a Single Backsight and Rounds setup type, which is represented by filter (S2). 
To resolve this issue, you will delete the first setup. 

10. Select Home > Data > Project Explorer. 

11. In the Project Explorer, expand the Imported Files node, right-click the filloop.jxl 
node, and select Expand. 

You can now quickly scan all of the filloop.jxl child nodes to identify the incorrect 
setup, which is displayed in red text. 

  

12. To delete the setup, right-click the Station Setup Plus (?) node and select Delete. 

13. Press F4, or click the red Compute Project Needed icon located in the Status Bar, to 
re-compute the project. 

  

14. Click on the Plan View and use your mouse wheel to zoom in. Press the mouse 
wheel and move the mouse to center the points. 
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With the view enlarged, you can more easily see the newly imported data. 

The Traverse Networks node in the Project Explorer indicates a traverse adjustment 
was performed in the field software, even though the adjustment was removed 
during import. 

  

 

Step 4. Correct a prism type error made in the field 

Because the surveyors in the field entered the incorrect prism type for observations 
within the mean angle w-x-w (M11), you must correct the error before proceeding. You 
will start by taking a look at the Point Derivation Report for point w. 

1. To view the Point Derivation Report, do the following: 
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a. Select Home > View > Zoom In or use your mouse wheel to zoom in on point w 
in the Plan View. 

b. Click point w and select Point: w [Points] in the list. 

c. Right-click in the Plan View and select Point Derivation Report in the list. 

The report displays in a browser window. The mean angle w-x-w (M11) is 
displayed with red values indicating the point exceeds tolerances you specified 
for mean angles earlier in the tutorial. This is the mean angle for which the 
prism type was incorrectly entered in the field.  

  

2. In the Project Explorer, expand Imported Files > filloop.jxl > x (S7) > Rounds > Set 1. 
Then right-click x-w (T161) and select Properties in the context menu. 

It might help if you right-click filloop.jxl and select Collapse before trying to navigate 
to x-w (T161).  

The properties for the observation are displayed in the Properties pane. 

  

Note that you could have selected any of the observations within the mean angle w-
x-w (M11) since you will be prompted to change them all. 

3. In the Target Information section of the Properties pane, select Large 63.5mm 
tiltable in the Prism type drop-down list. 
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4. When the message displays asking if you want to extend the prism change to all 
other observations within this mean angle, click Yes. 

The prism change is made to all observation within the mean angle. You must now 
re-compute the project. 

5. Press F4 to re-compute the project. 

A flag is no longer displayed for point w in the Plan View. 

6. Open another Point Derivations Report for point w and review the changes. 

  

You are now ready to disable outlying observations in the project. 

Step 5. Disable outlying observations 

A mean angle represents the combining and averaging of redundant observations to the 
same point. You can view residuals for any mean angle and, if you want, disable any 
outlying observations.  

For this tutorial, you will view residuals for the mean angle w-x-y (M12). This mean 
angle is flagged in the Plan View because there are observations within it that exceed 
tolerances you set for mean angles earlier in this tutorial. 
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1. In the Project Explorer, expand filloop.jxl > x (S7) > Rounds. Then, right-click w-x-y 
(M12) and select Mean Angle in the context menu. 

  

The Mean Angle Residuals dialog displays. 

  

Flags are displayed for two observations within the mean angle. You will disable the 
observation with the largest residual first to see if this corrects the other flagged 
observation. 

2. Uncheck the checkbox for observation x-y (T172). 

3. In the Change Observation Status dialog, click Yes to apply the same change to x-y 
(T170). 
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As you enable or disable observations, the means and residuals are re-calculated so 
you can immediately see the effects of the change. However, these changes are 
temporary and do not apply to the project until you click OK. 

You can click the Report button to view the Mean Angle Report, which provides 
additional information about each observation. 

Note that a flag still displays for x-y (T168), so you will need to disable that 
observation as well. 

4. Uncheck the checkbox for observation x-y (T168). 

5. In the Change Observation Status dialog, click Yes to apply the same change to x-y 
(T166). 

  

6. In the Mean Angle Residuals dialog, click OK. 

7. Press F4 to re-compute the project. 

Mean angle w-x-y (M12) is no longer flagged in the Plan View. 

  

Next, you will adjust the imported traverse. 

Step 6. Adjust the traverse 

You can now adjust the imported traverse. 

1. In the Project Explorer pane, click to expand the Traverse Networks node, right-
click fieldcheck (filloop.jxl), and select Adjust Traverse. 
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The Adjust Traverse pane displays showing a preview of the results of the 
adjustment on the Preview Results tab, including before and after misclosure 
values. 

  

To view adjustment setting, select the Settings tab. There is no need to make any 
changes for this tutorial. 

  

Note: For additional instructions on working with traverses, see the Creating and 
Adjusting Traverses tutorial. 

2. Select the Preview Results tab. 
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3. Click the Apply button. 

4. To see additional information about the traverse adjustment, click the Traverse 
Adjustment Report button located in the Traverse Adjustment pane toolbar. 

The report displays on a new tab in Survey Office. 

 

 

This completes the tutorial. 
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