
SURVEY OFFICE 
 

Spectra Geospatial, 10368 Westmoor Drive, Westminster, CO 80021, USA 
Spectra Geospatial, Rue Thomas Edison, ZAC de la Fleuriaye – BP 60433, 44474 Carquefou (Nantes), FRANCE 

© 2019, Trimble Inc. All rights reserved. Spectra  Geospatial  is a Division of Trimble Inc. Spectra Geospatial  and the Spectra Geospatial logo are trademarks of Trimble Inc. or its subsidiaries. All other trademarks 
are the property of their respective owners. 

www.spectrageospatial.com Page 1 
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About this tutorial 

In this tutorial, you will import points that were staked in the field ("as-staked" points). 
Then you will review the deltas for the as-staked points and their corresponding design 
points to ensure the appropriate tolerances were achieved in the field.  

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 

For this tutorial, you will use the project file Importing As-Staked Points.vce, which 
contains a surface, an alignment, and a corridor, along with corner points for a building 
stakeout and a CAD line for a sanitary sewer.  

Note: The downloaded ImportingAsStakedPoints folder contains this PDF file, a Data 
folder, and the Importing As-Staked Points.vce project file. You will import data from the 
Data folder later in this tutorial. 

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\ImportingAsStakedPoints\Importing As-Staked 
Points.vce and click Open. 

The project opens in the Survey Office window. Use your mouse wheel to zoom in 
on the Plan View tab as shown here. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 

Step 2. Specify as-staked point tolerances 

This project includes the design layout for a corridor (1 below), eight points for a 
building stakeout (2), and a CAD line for a sanitary sewer stakeout (3). The sewer line is 
intended to be staked out at a 10-ft right horizontal offset. The project also includes 
existing curb and fence lines (4).  

  

Note: Point labels and other objects have been hidden using the View Filter Manager to 
make the design layout easier to see.  

When as-staked point data is gathered in the field, the field software computes deltas 
for the as-staked points and their corresponding design points. When you import the 
field data into the project, the software identifies with a red flag and/or red label text 
any as-staked points whose deltas exceed the as-staked point tolerance you specify in 
the Project Settings dialog.  

Since this is the initial (rough grade) stakeout for this project, you are not concerned 
with vertical tolerances, and 0.20 ft should be adequate for a horizontal tolerance. 
Later, after initial excavation is complete, surveyors will be able to perform another 
stakeout for which you will specify a vertical tolerance and a smaller horizontal 
tolerance. 

To specify as-staked point tolerances, follow these steps: 

1. In the Quick Access Toolbar (located at the top of the Survey Office window), select 
Project Settings. 

2. In the Project Settings dialog, select Computations > As-Staked Points. 
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3. In the Horizontal tolerance field, enter 0.2. 

  

There is no need to change the Vertical tolerance since you will leave the Flag 
vertical out of tolerance option set to No. 

4. Click OK to close the Project Settings dialog. 

You are now ready to import the as-staked point data into your project. 

Step 3. Import as-staked point data 

In this step, you will import a JobXML (.jxl) file containing as-staked points and their 
corresponding design points, along with coordinate deltas. 

1. Select Home > Data Exchange > Import. 

The Import pane displays in the right side of the Survey Office window. 

2. In the Import pane, click the Browse button . 

3. In the Browse for Folder dialog, browse to ..\ImportingAsStakedPoints\Data and 
click OK. 

The content of the Data folder displays in the Select File(s) list in the Import pane. 

  

4. In the Select File(s) list, select job385.jxl and click the Import button. 

5. In the Project Coordinate System dialog, select the Keep the existing project 
definition option and click OK. 

The Merge Points dialog displays. 
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When you import a new data file into a project that includes a point with the same 
name as an existing point in the project, depending on your project configuration 
and the type of file you are importing, the Merge Points dialog may display showing 
all duplicate points. In the dialog, a check mark identifies each point pair that will be 
merged into a single point with the same name that includes the existing and new 
observations. 

Optionally, you can remove the check mark from any duplicate point to specify that 
the duplicate point be imported as a new point with the same name as the existing 
point. 

You can also select to rename a duplicate point using a variety of options. Instead of 
being merged with the existing project point, the duplicated point is imported with 
the new name.  

For this tutorial, you will not make any changes. 

6. In the Merge Points dialog, click Import. 

7. In the Import Errors dialog, click No. 

The import of the as-staked point data is complete. 

8. Using your mouse wheel, zoom in on the Plan View as shown here. 
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Next you will explore the various ways of viewing the imported as-staked point data. 

Step 4. View as-staked point data 

In the Project Explorer (select Home > Data > Project Explorer), as-staked points and 
their associated observations are displayed as nested nodes beneath the As-Staked 
Points node. 

  

As-staked points are also represented in the Project Explorer by "note" nodes nested 
beneath their associated observation nodes in the Imported Files lists.  

  

In the Plan View, as-staked points are represented by orange flag icons.  

  

If the coordinates for an as-staked point and its corresponding design point are not 
within the tolerances you specified in the Project Settings dialog, the as-staked point 
includes an out-of-tolerance flag. In this project, a red flag is displayed for each as-
staked point whose horizontal tolerance exceeds 0.20 ft.  
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To see a list of all flagged items in the project, including as-staked points that are out of 

tolerance, select Home > View > Flags Pane . The Flags Pane displays beneath the 
Plan View tab. 

  

As-staked points are also included in the Point Spreadsheet (select Home > Data > 
Points). 

To view properties for an as-staked point, right-click the point in the Project Explorer or 
Flags Pane and select Properties. Or, select the point in the Plan View, right-click, and 
select Properties. 

Step 5. View out-of-tolerance as-staked points 

Now you will take a closer look at some as-staked points that are out of tolerance. 

1. Use your mouse wheel to zoom in on the flagged as-staked point located on the 
north side of the building stakeout.  
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Zoom in farther until the as-staked point (1 below) and its corresponding design 
point (2) are clearly visible. 

  

You can see that the as-staked point is approximately 0.20 ft out of horizontal 
tolerance with the design point. 

2. Select the flagged as-staked point, right click, and select Properties. 

  

As shown in the Properties pane, the selected as-staked point ID is bldg4-1. Its 
corresponding design point ID is bldg4.  
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Note: When importing an as-staked point with the same ID as its corresponding 
design point, the as-staked point ID is appended with 1. 

3. If necessary, use the scroll bar to display the Grid Deltas section. 

  

4. Select Home > View > Flags Pane. 

A horizontal delta of 0.212 ft is displayed for as-staked point bldg4-1. This exceeds 
the specified tolerance of 0.20 ft. 

  

Next, you will take a look at a flagged as-staked point on the center line in the 
corridor at station 5+36.89.  

  

5. Use your mouse wheel to zoom in until the as-staked point (1 below) and its 
corresponding design station (5+36.89) and centerline offset (0) on the corridor (2 
below) are clearly visible.  

Note: If you have trouble identifying these points in the Plan View, select Home > 
View > View Filter Manager and select the Show feature code option on the Point 
tab. 



 

 

 www.spectrageospatial.com Page 10  
 

  

You can see that the as-staked point is approximately 0.20 ft out of horizontal 
tolerance with the centerline at station 5+36.89. 

6. Select the flagged as-staked point. 

  

As shown in the Properties pane, the selected as-staked point ID is rd0117.  

7. If necessary, use the scroll bar to display the Design Corridor Information and 
Linear Deltas sections. 

  

8. In the Flags Pane, scroll to the bottom of the list to see as-staked point rd0117. 

A horizontal delta of 0.206 ft is displayed for the point. This exceeds the specified 
tolerance of 0.20 ft. 
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Now you will look at the as-staked reports. 

Step 6. View as-staked reports 

Two as-staked reports are available: 

 As-Staked Report - This report includes all as-staked points in the project. It does 
not allow you to add or change columns in the report.  

 As-Staked Corridor Report - This report includes only the as-staked corridor points 
in the project. It allows you to add or change columns to provide even more detail. 

You will first view the As-Staked Corridor Report. But before you do, you will take a look 
at how you can customize the report to meet your specific needs. 

Note: To run either as-staked report, you must have a licensed version of Survey Office. 

1. In the Quick Access toolbar (located at the top of the SO window), select Reports > 
Report Options.  

2. In the Report Options pane, select As-Staked Corridor Report in the Reports list. 
Then click to expand the Column Display Options section. 

All possible column headings are shown, allowing you to select to show or hide 
them in the report. 

  

3. For this project, you will not make any changes, so click Cancel. 

You are now ready to view the As-Staked Corridor Report. When viewing a report, 
you have the option of first selecting the points you want to include in the report, or 
not making any point selection so that all of the points are included. For this 
tutorial, we want to include all of the corridor as-staked points, so no points should 
be selected. 

4. To ensure no points are selected, click somewhere in the Plan View other than upon 
a selectable object (for example, click the background). 
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5. In the Quick Access toolbar, select Reports > More Reports > As-Staked Corridor 
Report and click OK. 

The As-Staked Corridor Report displays on a new tab. 

  

When viewing the As-Staked Corridor Report, note the following: 

 By default, the As-Staked Corridor Report opens in Print Preview to better 
facilitate scrolling long reports. However, to enable the links in the report, you 
must first change the layout to the Normal view. In the toolbar at the top of the 

As-Staked Corridor Report tab, click the Print Layout button  to toggle to 
Normal view. 

 In Normal view, if you click a colored as-staked point name, that point is 
selected in the project. 

  

 Red text for station deltas (1 below) and offset deltas (2) indicates the as-staked 
point is out of horizontal tolerance and has been flagged in the project. 

  

 If the report contains more than one page, the navigational controls located at 
the top of the report allow you to move from page to page. 
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 To increase or decrease the magnification of the view, use the Zoom control 
located at the top of the report. 

  

 To print the report, or export it to an Excel spreadsheet, a Word document, or 
an Acrobat PDF file, use the controls located at the top of the report. This is 
useful if you want to provide the report to a client or other team member.  

  

Next you will look at the As-Staked Report. 

6. In the Plan View, select the building points along with some of the sanitary sewer 
points by drawing a box around them. 

Only these points will be included in the report. 

  

7. Select Home > Reports > As-Staked Report. In the Quick Access toolbar, select 
Reports > As-Staked Report. 

The As-Staked Report displays on a new tab. 

8. Take a moment to look at the information contained in the report. 

You are done viewing the as-staked reports. Next you will view a media file contained in 
the project. 
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Step 7. View a media file 

The project includes a photograph of a stake being placed in the field, which you can 
open from various locations, including the Project Explorer and the Plan View. In this 
step, you will learn how to access and view the photo from both of these locations. 

1. In the Project Explorer (Home > Data > Project Explorer), expand the Media Files 
node and the ss18 media folder node nested beneath it. 

  

ss18 is an as-staked point for the sanitary sewer. This is where the photo was taken. 

2. Right-click img014.jpg and select Open img014.jpg to view the photo in your default 
photo viewer 

  

3. Close the photo viewer window. 

You will now access the same photo from the Plan View, and view properties for the 
media folder. 

4. In the Plan View, select the orange media folder icon (Media Folder: ss18), which is 
next to the as-staked sanitary sewer point ss18 (see below). Then right-click and 
select Properties. 
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The Properties pane for media folder ss18 is displayed. 

  

5. Click the button located to the right of the File path to view the photo in your 
default photo viewer. 

Next you will view the corridor in 3D View. 

Step 8. View as-staked points in 3D 

To see how the corridor design compares to the existing ground as it was staked, you 
will look at the corridor using the 3D View. 

1. Select Home > View > 3D View. Then use your mouse wheel to zoom in on the 
corridor as shown here. 
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2. Select Home > View >3D View > 3D View Settings. 

3. In the 3D View Settings pane, do the following: 

a. In the Vertical angle field, enter 72. 

b. In the Azimuth field, enter 147. 

c. In the Factor field, enter 4.5. 

4. Use your mouse wheel to zoom in on the beginning of the corridor (station 0+00.00) 
as shown here. 

  

In this view, you can see how the existing ground (as identified by the red line drawn 
through the as-staked points below) differs from the corridor design at station 
0+00.00. 
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This completes the tutorial. 
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