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About this tutorial 

In this tutorial, you will import a text (.csv) file containing ground control point (GCP) 
names and coordinates and a JobXML (.jxl) file containing aerial survey data. 
(Referenced photo images are automatically imported along with the JobXML (.jxl) file.) 
Then you will adjust the aerial photo stations to ensure the highest precision and create 
three deliverables: an orthomosaic, a point cloud, and a raster-based digital surface 
model (DSM). 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Overview of aerial survey data 

Aerial survey data is collected using an unmanned aircraft system (UAS), such as a 
Trimble UX5 aerial mapping and surveying system. 

An aerial survey flight mission consists of an interconnected series of aerial photo 
station images, along with autonomous GNSS station positions recorded with each 
image, intended to be processed as a single unit. A single flight mission can include one 
or more flight blocks, each intended to cover a single polygonal area.  

The following figure shows the area that could be covered by either two separate flight 
missions or two separate flight blocks contained in a single flight mission. 

  

Each time an aerial photo image is taken, an aerial photo station is created, much like a 
terrestrial photo station. The following figure shows the aerial photo stations created 
for the flight mission.  
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Before you can use imported aerial survey data to create an orthomosaic, raster-based 
digital surface model (DSM), or point cloud, you must adjust the aerial photo stations 
using the Adjust Photo Stations command. The command allows you to make two types 
of adjustments, which must be performed in the sequence shown here: 

 Relative adjustment - In this adjustment, SO automatically identifies tie points (a 
point in a photo image that represents the same location in an adjacent image) in 
aerial images and matches them to correctly orient the aerial photo stations to each 
other and reference them to the ground based on autonomous GNSS positions 
recorded when the photo images are taken. This is the minimal adjustment required 
prior to creating aerial survey deliverables from UAS data.  

 Absolute adjustment - In this adjustment, SO adjusts the photo station points more 
precisely to the ground using three or more ground control points (GCPs) for 
autonomous UAS data. A camera calibration is included in the absolute adjustment 
process to provide the highest precision.  

 

Step 1. Open the project 

For this tutorial, you will use the project file Processing Aerial Survey Data.vce.  

Note: The downloaded ProcessingAerialSurveyData folder contains this PDF file, a Data 
folder, and the Processing Aerial Survey Data.vce project file. You will import data from 
the Data folder later in this tutorial. 

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\ProcessingAerialSurveyData\Processing Aerial 
Survey Data.vce and click Open. 

The project opens in the Survey Office window. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 

Step 2. Select the coordinate system 

Before you import aerial survey data into your project, you must select the correct 
coordinate system for the survey. 

1. In the SO ribbon, select Photogrammetry > Setup > Change Coordinate System to 
display the Change Coordinate System dialog. 

2. If it is not already selected, select the Coordinate System and Zone option. 

  

3. Do the following: 

a. In the Coordinate System Group list, select United States/State Plane 1983. 
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b. In the Zone list, select Wyoming East 4901. 

c. Click Next. 

The Select Geoid Model dialog displays. 

  

The Predefined Geoid model option is selected by default. (If it is not selected, 
select it now.) 

The Coordinate System Manager is a standalone utility that gives you access to your 
coordinate system database (Current.csd). In the Coordinate System Manager, 
geoid models can be predefined. These predefined models are listed in the 
Predefined Geoid model list. 

The default model selection is GEOID 18 (Conus). The default quality setting is 
Unknown Quality. There is no need to change the default settings. In addition, there 
is no need to specify a vertical datum name. 

Note: For this project, you will be importing ground control points (GCPs) with grid 
coordinates of Control Quality, so there is no need to change the default Unknown 
Quality for the geoid model. However, if the control points were derived from GNSS 
data and you were using a Survey Quality geoid, you would need to set the geoid 
model to Survey Quality to avoid degrading the quality of the elevation of the 
points. If you did not have a Survey Quality geoid, you would not be able to use 
GNSS-derived control points. 

4. Click the Finish button. 

You are now ready to import aerial survey data into your project. 

Step 3. Import data 

For this project, you will import two data files: 

 A text (.csv) file containing the ground control points (GCPs) for the project. 

 A JobXML (.jxl) file containing aerial survey data from a single flight mission: X100 
site 

To import data, follow these steps: 
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1. Select Home > Data Exchange > Import. 

The Import pane opens in the right side of the Survey Office window. 

2. In the Import pane, click the Browse button . 

3. In the Browse for Folder dialog, browse to ..\ProcessingAerialSurveyData\Data and 
click OK. 

The content of the Data folder displays in the Select File(s) list in the Import pane 

  

4. In the Select File(s) list, select 300 Series Control.csv and click the Import button. 

5. In the Import Format Editor dialog, verify the selected definition is P,E,N,elev,Code 
(Control). Then, click the Import button. 

  

The newly imported ground control points are displayed in the Plan View. 

You will use these ground control points to adjust the aerial photo stations later in 
this tutorial. 
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You are now ready to import a JobXML (.jxl) file containing the aerial survey data. 

6. Select Home > Data Exchange > Import and import the GuernseyFebFlt1_SO6.jxl file. 

The newly imported aerial survey data is displayed in the Plan View. In addition, the 
photo image files displayed in the Select File(s) list are copied to the project folder. 

  

The imported GuernseyFebFlt1_SO6.jxl file contains the GuernseyFebFlt1_SO6 flight 
mission, as shown in Home > Data > Project Explorer. 
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In the Plan View, the icons representing the aerial photo stations point in the 
direction the aircraft was traveling when the image was recorded. Its black interior 
color indicates the station has not yet been adjusted. A connecting line runs through 
each of the aerial photo stations contained in the flight block. A polygonal border 
line identifies the perimeter of the flight mission. 

Underneath each photo station icon is a thumbnail of the captured image, which 
can be more easily viewed when you zoom in on the Plan View. 

 

 

Step 4. Perform a relative photo station adjustment 

In this adjustment, SO automatically identifies tie points (a point in a photo image that 
represents the same location in an adjacent image) in aerial images and matches them 
to correctly orient the aerial photo stations to each other and reference them to the 
ground based on autonomous GNSS positions recorded when the photo images are 
taken. This is the minimal adjustment required prior to creating aerial survey 
deliverables from UAS data.  

To perform a relative adjustment of the aerial survey photo stations, follow these steps: 
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1. In the SO ribbon, select Photogrammetry > Adjust > Adjust Photo Stations.  

The Adjust Photo Stations command pane displays. Since GuernseyFebFlt1_SO6 is 
the only flight mission in the project, it is selected by default in the Mission drop-
down list. 

  

2. On the Relative Adjustment tab, click the Adjust button. 

The aerial photo stations within the selected flight mission are adjusted using tie 
points and their autonomous GNSS positions. The Process View tab displays to show 
the progress of the process.  

Notes:  
- Unless you have changed the default Process Monitoring settings in the Options 
dialog, the progress also displays in the Survey Office button on the Windows 
taskbar by way of a colored bar moving across the button's background. When the 
process is complete, a check mark is displayed on the button and a notification is 
displayed in a pop-up Desktop Alert. 
- You cannot perform other aerial survey tasks until processing is complete. 

When the tie point adjustment process is complete, the Apply Adjustment and 
Discard buttons are displayed on the Process View tab. 

  

Note: The adjustment process can take a long period of time to complete if you are 
working with a large amount of data. If your computer goes to "sleep" during 
processing, the process will stop and will not re-continue until the computer is 
"awakened." To prevent this from happening, you can extend the period before 
which your computer goes sleep by selecting Power & sleep in your Windows 
Settings. 
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3. On the Process View tab, click the Apply Adjustment button to save the adjustment 
results in the project.  

4. In the Flight Mission Adjustment Report message dialog that displays, click Yes to 
display the report. 

The report includes the following information (as applicable), much of it in easy-to-
understand graphical views. 

 General project information (project name, process type and date/time, 
resulting file, number of cameras and images used, number of strips, flying and 
terrain height, average photo scale, and coordinate system) 

 Flight overview information (camera locations, strip definitions, and tie points) 

 Tie point distribution (distribution and number of images containing each point) 

 Camera calibration (camera data, distortion values, and image residuals) 

 Block adjustment results (parameters, accuracy, and mean standard deviation of 
translations/rotations/ground control points) 

 Exterior orientation (camera locations and standard deviations)  

 GNSS statistics (residuals and tie point locations) 

 Ground control points (if applicable; errors, residuals, and standard deviations) 
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By viewing the adjustment results, you can often make a determination about the 
precision of the adjusted aerial survey data. After viewing the report, you can close 
it. 

In SO, the adjustment is applied and the project is automatically re-computed. The 
aerial photo station icons displayed in the Project Explorer and Plan View change 
from black to indicate they have been adjusted with tie points.  
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You can see that eight of the points include red flags in the Plan View. If you select 
Home > View > Flags Pane, you can see the points exceed the computational 
settings for horizontal point tolerances specified in the Project Settings dialog. 

  

For additional information, select any of the flagged points in the Project Explorer 
or Plan View, right click, and select Point Derivations Report. 

  

When you perform an adjustment using ground control points, as described in the 
next step, these horizontal deltas should fall within the specified tolerances. 

The Results tab displays information about the tie point adjustment. By viewing the 
adjustment results, you can make some determination about the precision of the 
adjusted aerial survey data. 
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Note: If necessary, click and drag the command pane's left border to widen the 
pane, making it easier to read the labels. 

Next, you will use the ground control points (GCPs) you imported into the project to 
more precisely adjust the aerial photo stations. 

Step 5. Perform an absolute photo station adjustment 

In this adjustment, SO adjusts the photo station points more precisely to the ground 
using three or more ground control points (GCPs) for autonomous UAS data. A camera 
calibration is included in the absolute adjustment process to provide the highest 
precision.  

A ground control point (GCP) is an accurately surveyed coordinate location for a physical 
feature that can be identified on the ground and is used to georeference images. (For 
this project, easily identifiable printed targets were used to identify ground control 
points.) This adjustment allows you to make photogrammetry observations to the 
ground control points to provide more precise referencing of the aerial photo stations 
than was possible using only the adjustment with tie points. 

To perform an absolute adjustment of the aerial survey photo stations, follow these 
steps: 

1. In the Adjust Photo Stations command pane, select the Absolute Adjustment tab. 
Then click in the Point ID field and select ground control point 11 in the Project 
Explorer or Plan View. 

You can also type the control point ID in the field. 

  

Note: Only control points with coordinate quality of Control or Survey can be used in 
an adjustment. The control points in this project all have Control quality. 

2. Click the Add button  located to the right of the field, or press the Enter key. 

The following occur: 

 The selected point is added to the Control Points list.  



 

 

 www.spectrageospatial.com Page 14  
 

  

 The aerial photo stations with photo images most likely to include the control 
point are displayed in the Photo stations list. 

 The photo image from the first station in the Photo stations list is displayed on 
a new Station View tab. The associated control point is used to center the 
photo image on the tab. 

  

In the Control Points list, you can use the Status drop-down list to select any of the 
following status options for the selected ground control point: 

 Enabled - Include all photogrammetry observations of the control point in the 
adjustment.  

 As check - Make photogrammetry observations to the control point to calculate 
the point's position, but do not include the control point in the adjustment. This 
control point will be used as a check for precision. 

 Disabled - Do not use the control point in the adjustment. 

For this tutorial, you will keep the default status of Enabled. 
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3. To make a photogrammetry observation to the control point on the newly displayed 
Station View tab, click in the Pixel Picker field. Then, using the Pixel Picker view 
control, click as accurately as possible on the control point target located near the 
vehicle in the photo image (1 in the figure below). 

Note: In the image for photo station R0011747, two ground targets can be seen. Do 
not select the target located farthest from the vehicle (2 in the figure below). This 
target is not located on a ground control point, but instead it is identifying a point of 
interest that can be surveyed using photogrammetry observations after the 
adjustment is complete. 

  

When using the Pixel Picker, note the following: 

 Toggle between the two Pixel Picker display options – dynamic view (1 below) 
and static view (2 below) – by pressing Ctrl + Shift.  
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The dynamic view option causes the Pixel Picker to display as a magnifier with a 
reticle, enabling you to dynamically select the precise location for a 
photogrammetry observation on the photo image. To change the reticle for the 
Pixel Picker, press Ctrl + Alt. 

The static view option causes the Pixel Picker to display as a small selection 
cursor that, when clicked, opens a window with a magnified view of the photo 
image showing the selected area. You can then select the precise location for a 
photogrammetry observation on the photo image in the magnified view. 

 Use your mouse wheel to zoom in or out. Press the mouse wheel and move 
your mouse to move the image on the Station View tab. 

 Once the Pixel Picker is close to the object you want to select, you can press the 
arrow keys on your keyboard to move it in small increments. When you are 
ready to make your selection, press your left mouse button or press the Enter 
key. 

After you take your observation, the photo station's Status changes to "Enabled" in 
the Photo stations list. 
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By default, the Auto advance on select option is selected to specify that the next 
station in the list be automatically selected each time you make a photogrammetry 
observation. 

  

4. Repeat this procedure to make two more photogrammetry observations to the 
selected ground control point, for a total of three observations.  

The stations positioned higher in the Station list are most likely to provide a view of 
the control point. To ensure the highest precision, you would typically include as 
many control points as possible in the adjustment, and ensure the ones you do 
include are spread out as much as possible across the surveyed area. You would also 
want to make as many photogrammetry observations as possible to each ground 
control point. However, for this tutorial, you will make three observations to each of 
the five available control points. 

An epipolar line representing each photogrammetry observation is displayed in 
subsequent photo images and can be used to more easily locate the ground control 
point target in the photo image. Notice that your second and third observations (1 
in the figure below) together do not provide very good geometry because the angle 
between them is less than 30°. But the three observations together should be 
adequate. If ever in doubt, you can make additional observations. 
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5. After making your third observation to ground control point 11, click in the Point ID 
field, select ground control point 12, and make three observations to the point. 
Then, repeat this procedure for ground control points 13, 14, and 15. 

Control point 12: 

 

Control point 13: 

 

Control point 14: 
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Control point 15: 

 

6. After you have made three photogrammetry observations each to ground control 
points 11 through 15, click the Adjust button. 

The selected aerial photo stations are adjusted using the ground control points. The 
Process View tab displays to show the progress of the absolute adjustment process.  

Notes:  
- As with the relative adjustment, progress also displays on the SO taskbar button. 
When the process is complete, a check mark is displayed on the button and a 
notification is displayed in a pop-up Desktop Alert. 
- You cannot perform other aerial survey tasks until processing is complete. 

When processing is complete, the Apply Adjustment and Discard buttons are 
displayed on the Process View tab. 

7. On the Process View tab, click Apply Adjustment to save the adjustment results.  

8. In the Flight Mission Adjustment Report message dialog that displays, click No. 

The adjustment is applied and the project is automatically re-computed. The aerial 
photo station icons displayed in the Project Explorer and Plan View change from 
yellow to white to indicate they are adjusted with ground control points. 
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Note that only one of the eight points that included out-of-tolerance flags still 
includes a flag. Photogrammetry observations are identified by red lines.  

9. Select the Results tab to view information about the control point adjustment.  

In addition to the information displayed as a result of the adjustment with tie 
points, the Results tab now also includes observation residuals. By viewing the 
adjustment results, you can make some determination about the precision of the 
adjusted aerial survey data. 

  

Optionally, based on your results, you could choose to remove one or more ground 
control points from the adjustment. To do this, on the Absolute Adjustment tab you 
would select Disabled for the point in the Status drop-down list and click the Adjust 
button to re-adjust the aerial photo stations. However, for this tutorial there is no 
need to remove ground control points. 

You are now ready to create orthomosaic, raster-based digital surface model (DSM), and 
point cloud deliverables from the adjusted flight mission data. 

Step 6. Create aerial survey deliverables 

In this step, you will use the Create Orthomosaic command to create an orthomosaic 
from adjusted flight data. An orthomosaic is a photo composed of multiple 
georeferenced orthophotos that have been corrected for topographic relief and lens 
distortion. It can be used to measure true flat distances because it is an orthographic 
(non-perspective) representation of the Earth's surface. 

When an orthomosaic file is created, the following files are automatically created as 
well: 

 Raster-based digital surface model (DSM) - A representation of the topography of 
the earth in digital format (that is, by coordinates and numerical descriptions of 
altitude). DSMs are often used in geographic information systems. The DSM you will 
create is represented as a raster (a grid of cells, also known as a height map when 
representing elevation). 
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 Point cloud - A set of vertices in a three-dimensional coordinate system that are 
usually defined by X, Y, and Z coordinates, and are intended to be representative of 
the external surface of an object.  

You can select to save or not save these adjunct files. You can also create either one of 
these deliverables using the Create Raster DSM or Create Point Cloud command. 
However, for this tutorial you will select to save the raster DSM and point cloud created 
along with the orthomosaic. 

Notes: 
- A flight mission cannot be used to create an aerial survey deliverables unless it has 
been adjusted using tie points. 
- Although it is not a requirement that you also perform an adjustment with ground 
control points prior to creating deliverables, performing the adjustment ensures that 
your flight mission is of the highest survey quality and that deliverables are as accurate 
as possible. 

To create aerial survey deliverables, follow these steps: 

1. In the SO ribbon, select Home > View > View Filter Manager. Then uncheck 
Referenced Image (Plan View) in the Photogrammetry list. 

This hides the thumbnail image located beneath each photo station, making it easier 
to view the orthomosaic image you will create in this procedure. 

2. In the ribbon, select Photogrammetry > Deliverables > Create Orthomosaic. 

The Create Orthomosaic command pane displays. 

  

If you had created a closed-line boundary around a specific area for which you 
wanted to create an orthomosaic, you could select it using the Boundary (optional) 
field. But, for this tutorial, you will leave this field blank to create an orthomosaic for 
the entire area covered by the flight mission. 

Note: To quickly create a boundary, you can click the Create Boundary button 
located in the Create Orthomosaic command pane toolbar. 
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3. In the Resolution drop-down list, ensure High resolution (ground distance per photo 
pixel) is selected for the orthomosaic.  

Optionally, you could type in a ground distance value. 

Do not change the default TIFF (*.tiff) format selected in the File format drop-down 
list. 

The Output file field defaults to use the name of the flight mission for the 
orthomosaic file name and the file path to the project folder. There is no need to 
change this information. 

Warning! To avoid unexpected results, do not create an orthomosaic file that has 
the same name as an orthomosaic file that has already been imported into your 
project. In addition, do not import an orthomosaic file into your project that has the 
same name as an orthomosaic file that has already been imported. 

Do not make any changes in the Point cloud (optional) or Raster DSM (optional) 
drop-down lists. These files will also be saved into the project folder using the same 
name as the flight mission. 

Note: Because the point cloud file and raster DSM file are automatically created 
during the creation of the orthomosaic file regardless of your selection in the Point 
cloud (optional) and Raster DSM (optional) drop-down lists, no extra processing 
time is required if you decide to save them. 

4. Click the Create button. 

The Process View tab displays to show the progress of the file creation process.  

When processing is complete, an Import button and Done button display on the 
Process View tab.  

5. Click the Import button to save the newly created orthomosaic file in your project 
folder and import it into your project.  

If you click the Done button, the newly created orthomosaic file is saved to your 
project folder without importing it into your project. 

The newly created point cloud file and raster DSM file are also saved to your project 
folder. 

6. In the Import Errors message dialog, click No. 

7. To view the newly created orthomosaic in SO, select the Plan View tab.  
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This concludes the tutorial steps for Processing Aerial Survey Data. However, if you 
would like to try some additional exercises working with the tutorial data, see the next 
section: "Additional exercises." 

Additional exercises 

Following are some additional exercises you might perform to broaden your experience 
with aerial survey data using Survey Office. 

 Import the newly created point cloud file GuernseyFebFlt1_SO6.PointCloud.las from 
the project folder into Survey Office, and view it in the 3D View (select Home > 
View > 3D View). 
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Warning! To avoid unexpected results, do not import a point cloud file into your 
project that has the same name as a point cloud file that has already been imported. 

 Import the newly created raster-based digital surface model (DSM) 
GuernseyFebFlt1_SO6.RasterDSM.tif from the project folder into Survey Office and 
view it in the Plan View. 

Hint: If an imported point cloud is displayed in the project, use the View Filter 
Manager to hide it so that you can clearly view  the raster DSM in the Plan View. 
Uncheck it in the View Filter Manager to hide it. 
 

  

Higher elevations display in warmer colors (for example, orange and yellow); lower 
elevations display in cooler colors (for example, blue and green). 

  

Warning! To avoid unexpected results, do not import a raster DSM file into your 
project that has the same name as a raster DSM file that has already been imported. 

 Use the Home > View > Google Earth command to view the flight mission in Google 
Earth. 

Hint: Use the Select All option in the Selected entities field to ensure all applicable 
objects in the project are selected for export to Google Earth. 
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 Use the Photogrammetry > Data > Measure Photo Point command to create a new 
point 20 by making photogrammetry measurements (observations) to the target 
located farther from the vehicle in the images for photo stations R0011740, 
R0011745, and R011747. See the Measuring Photogrammetry Points tutorial or the 
online Help for instructions. 

Hint: If an imported point cloud is displayed in the project, use the View Filter 
Manager to hide it so that you can clearly view the photo images on the Station 
View tabs to make the measurements. 
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After making the three photogrammetry measurements to the new point 20 and re-
computing the project, right click the point in the Project Explorer and select to 
view the Point Derivations report. Note the observation residuals for the point and 
the overall strength of figure. (Your values may differ from the values shown in the 
figure below.) 
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