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Creating Projected Surfaces  
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About this tutorial 

In this tutorial, you will create a projected (non-horizontal) surface for each of two point 
clouds of an exterior building wall that were collected before and after adjacent ground 
excavation to determine wall movement resulting from the excavation. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 

For this tutorial, you will work with a project that includes two imported points clouds 
that include a section of an exterior wall that is being monitored for changes. One point 
cloud was collected before adjacent ground excavation work and one was collected 
after excavation was completed.  

Note: The downloaded CreatingProjectedSurfaces folder contains this PDF file, a 
Creating Projected Surfaces.vce project file, and a Creating Projected Surfaces project 
folder. 

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\CreatingProjectedSurfaces\Creating Projected 
Surfaces.vce and click Open. 

The project opens in the Survey Office window. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can 
save it with a new name by selecting File > Save Project As. Then, you can re-open 
the project to continue the tutorial at a later time. 

3. If the Project Explorer is not already displayed, in the SO ribbon, select Home > 
Data > Project Explorer to display it. 

In the Project Explorer, you can see the two point clouds that have been imported 
into the project: Initial Building Scan and Monitoring Scan 1. 

  

4. In the SO ribbon, select Home > View > 3D View. Then, use your right-mouse button 
and mouse wheel (roll and press-and-drag) to navigate the 3D view to see the 
exterior wall you want to monitor, as shown here.  

  



 

 

 www.spectrageospatial.com Page 4  
 

Optionally, you can change your background to black (if it is not already black), 
which is typically used to view point clouds on the 3D View tab. Just click  the Toggle 
Background Color button located at the bottom of the SO window. However, for 
this tutorial you will continue to use a white background to make it easier to make 
selections on the Plan View tab and avoid toggling back and forth 

  

 

 

 

Step 2. Create the first projected surface 

In this step, you will create a projected surface on the building wall for the Initial 
Building Scan point cloud. 

1. In the SO ribbon, select Home > View > View Filter Manager to display the View 
Filter Manager.  
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2. Uncheck the Monitoring Scan 1 Scan check box and ensure that the Initial Building 
Scan Scan check box is checked so that only the Initial Building Scan point cloud is 
displayed. 

  

3. On the Plan View, use your cursor to make a selection of the wall points as shown 
here. 

  

4. In the SO ribbon, select Point Clouds > Regions > Keep In to hide all of the 
non-selected scan points. 



 

 

 www.spectrageospatial.com Page 6  
 

  

5. Select the remaining points in the Plan View and then select Surfaces > Projected > 
Create Projected Surface. 
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6. In the Name field, enter Initial. 

7. In the Plane drop-down list, select <<New Plane...>>. 

  

The Plane Manager displays. 

  

8. In the Plane Manager, do the following: 

a. Click the New button. 

b. In the Name field, enter Wall Monitoring. 

c. Select the Vertical plane option. 

d. Click in the Point 1 field and click on the left end of the selected points in the 
Plan View. Then click on the right end to make your Point 2 selection. 

  

The intent is to ensure the plane is roughly parallel to the entire wall. 

e. Click Close. 
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Wall Monitoring is selected in the Plane drop-down list in the Create Projected 
Surface command pane. 

  

9. Click OK. 

Processing status is displayed at the bottom of the window. When complete, the 
new Surfaces > Initial node displays in the Project Explorer. 

 

10. Visually inspect the new surface in the 3D View.  

  

Note that flags may display due to errors in the triangulation of the surface. Flags 
typically indicate that two points are on top of each other, with respect to the plane 
definition. This is not a big concern if they are isolated. If necessary, they can be 
cropped out of the surface later in this procedure when you create a surface 
boundary.  

Step 3. Create the second projected surface 
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In this step, you will create a projected surface on the building wall for the Monitoring 
Scan point cloud.  

1. In the View Filter Manager, uncheck the Initial Building Scan Scan check box and 
check the Monitoring Scan 1 Scan check box so that only the Monitoring Scan 1 
point cloud displays in the graphic views. 

  

Then, in the Surface section, uncheck the new Initial surface check box. 

  

2. In the SO ribbon, select Point Clouds > Regions > Restore All to display all of the 
Monitoring Scan point cloud scan points 

3. On the Plan View, make a selection of the wall points as you did for the first 
projected surface. 

  

4. Select Point Clouds > Regions > Keep In to hide all of the non-selected scan 
points. 
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5. Select the remaining points in the Plan View and then select Surfaces > Projected > 
Create Projected Surface. 

  

6. In the Name field, enter Monitoring. 

7. In the Plane drop-down list, ensure Wall Monitoring is selected. 

8. Click OK. 

Processing status is displayed at the bottom of the window. When complete, the 
new Monitoring surface node displays in the Project Explorer. 
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Step 4. Create a surface boundary 

In this step, you will create a surface boundary to crop out parts of the surfaces that will 
be invalid for analysis: areas where the surface mesh did not triangulate properly. This 
can be caused by geometric irregularities in the surfaces or by points that define other 
surfaces perpendicular to the specified plane.  

1. In the View Filter Manager, uncheck the Monitoring Scan 1 Scan check box so that 
neither point cloud is displayed in the graphic views. 

  

Then, in the Surface section, check the Initial surface check box so that both 
surfaces are displayed in the graphic views. 

  

  

2. In the SO ribbon, select Point Clouds > View > Cutting Plane View to display the 
Cutting Plane View tab. 
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The Cutting Plane View tab displays showing a 2D view of the Wall Monitoring 
plane, which includes the two projected surfaces.  

3. In the Cutting Plane View, ensure that both check boxes are unchecked. 

  

The Cutting Plane View is a powerful tool that provides a 2D view of any user-
defined plane in your project. You can use it, for example, to create CAD line work 
(for example, linework tracing features on a building facade) that can be printed as a 
dynaview in a sheet set and/or exported to other applications via various CAD 
exporters. For this tutorial, you will use it to draw a CAD rectangle to use as a 
surface boundary. 

Optionally, the Apply cutting plane check box can be used in conjunction with the 
specified Cutting plane thickness value to define the thickness of the plane, which 
in turn causes more or less scan points to be displayed. In this case, it is not 
necessary. 

Next, you will draw a rectangle around the area you want to include in each of the 
two surfaces. 

4. To draw a rectangle that defines the boundaries for the two surfaces, do the 
following: 

a. In the SO ribbon, select CAD > Lines > Create Rectangle. 

  

There is no need to enter a Name, change the Layer, or change the Elevation. 

b. Click in the Corner one field and then click once in the upper-left corner as 
shown here (1). Then move the cursor to the lower right corner and click a 
second time (2).  
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c. Right-click and select [Close] to close the Create Rectangle command pane. 

d. In the Cutting Plan View, select the new rectangle (CAD Polyline). 

Note that the bottom portion of the wall has been cropped out because points 
collected there were partially blocked by a fence. 

  

5. Close the Cutting Plane View tab. 

6. In the SO ribbon, select Surfaces > Create > Add/Remove Surface Boundaries. 

  

7. In the Add/Remove Surface Boundaries command pane, do the following: 

a. In the Surface list, select the new projected surface Initial. 
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b. Ensure that the new rectangle is selected in the Boundaries to add or remove 
field. 

c. Click the Add button to add the new boundary to the surface. 

The progress of the process is displayed in the Status Bar at the bottom of the 
SO window. 

d. When the process is complete, in the Surface list, select the new projected 
surface Monitoring. 

e. Click the Add button  

When processing is complete, the two cropped surfaces display directly on top of 
each other in the graphic views. 
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Step 5. Create a cut/fill map 

In this step, you will create a cut/fill map and modify its properties. The map will be 
used to illustrate the movement of the wall from prior to post-excavation. This tool can 
be used to make judgments on whether shoring is appropriate, or if work conditions are 
safe.  

1. In the SO ribbon, select Surfaces > Edit > Create Cut/Fill Map. 

  

2. In the Name field, enter WallCutFill. 

3. In the Initial drop-down list, select Initial. 

4. In the Final drop-down list, select Monitoring. 

Since the display of a cut/fill map can affect performance, you will create a new 
layer for this cut/fill map so that you can show and hide it as necessary using the 
View Filter Manager. 

5. In the Layer drop-down list, select <<New Layer>> to display the Layer Manager 
dialog. 

  

6. In the New Layer 1 field, enter WallCutFill. Then, click Close. 

WallCutFill is selected in the Layer drop-down list in the Create Cut/Fill Map 
command pane. 
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Next, you will specify a text size for cut/fill map labels that is smaller than the 
default Standard size of 10.0 sheet units. 

7. In the Text style drop-down list, select <<New style>> to display the Text Style 
Manager dialog. 

  

8. Do the following: 

a. Click the New button. 

b. In the Style name field, enter WallCutFill. 

c. In the Size: Height field, enter 0.10. 

d. Click OK. 

WallCutFill is selected in the Text style drop-down list in the Create Cut/Fill Map 
command pane. 

9. In the Grid spacing field, enter 0.50. 

  

10. Click OK. 

Processing make take several minutes to complete (progress is displayed in the 
Status Bar). When processing is complete, the new WallCutFill map node displays in 
the Project Explorer. 
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Next you will make a modification to a property for the WallCutFill map that will 
enable you to shorten processing times if you make any changes. 

11. In the Project Explorer, right-click the new WallCutFill node and select Properties. 
Then, in the Display daylight line drop-down list, select No 

  

12. In the View Filter Manager, uncheck the Initial and Monitoring surfaces, leaving just 
the WallCutFill surface checked. 

  

When viewed straight on, the WallCutFill map displays in the 3D View as shown 
here (). A cut or fill value is displayed every 0.500 m along the wall. The small cut 
and fill values indicate very little (millimeter-level) movement in the wall. 
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Zoomed-in view: 

  

The wall's movement is on the order of millimeters, so changing the color mapping 
will not have as much of an affect as if you were changing it for an earthwork 
project. However, to create a better visual representation of the wall’s movement, 
you will make a change to the Project Settings for the WallCutFill map. 

13. In the Quick Access tool bar (located at the top of the SO window), select Project 
Settings. 
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14. In the Project Settings dialog, do the following: 

a. In the left navigation pane select Computations > Surface.  

b. In the Grid Label Settings section, enter 0.001 m for Above design grade 
tolerance and Below design grade tolerance. 

  

c. Click OK. 

When processing is complete, you can zoom out to see a preponderance of red on 
the right end of the wall, which indicates that more "cuts" are required for the Initial 
surface to make it match the Monitoring surface. In other words, it indicates more 
movement (slight as it may be) on that end of the wall. 



 

 

 www.spectrageospatial.com Page 20  
 

  

 

Step 6. Create an Earthwork report 

In this step, you will create an Earthwork report to further determine movement in the 
wall. 

1. In the Quick Access toolbar, select Reports > Earthwork Report. 

  

2. Select the Surface to surface option. 

3. In the Initial drop-down list select Initial. 

4. In the Final drop-down list, ensure Monitoring is selected. 

5. Ensure the Volume totals only option (farther down in the command pane) is 
selected. 

6. Click OK. 

When the report generation process is complete, the Earthwork Volume report 
displays in your browser window. 
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Note that although no volumes were identified, due to the very slight movement of 
the wall, the "cut" and "fill" areas in this example are 2.9 m² and 0.1 m² respectively, 
indicating at least some movement. (Your results may vary.) Also note that the 
maximum depth of cut and fill material in this example is 0.599 m and 0.243 m 
respectively. (Again, your results may vary.) Typically, this would indicate larger cut 
and fill volumes. But in this case, these values represent large deviations in the 
cut/fill map resulting from the fact that some areas of the surfaces were nearly 
vertical with respect to the plane definition. 

This completes the tutorial. 
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