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About this tutorial 

This tutorial explains how to use the Extract Point Feature command to select an object 
in a point cloud (for example, a light pole or a tree) and automatically create a new 
point at the base of the object with an assigned feature code and feature attributes. You 
will create both individual points (manual mode) and a batch of points (automatic 
mode). To assist in populating attribute values for the feature from extracted scan data, 
you will map the feature code's attributes, which are defined in an imported Feature 
Definition Library (.fxl) file, to attributes extracted by the command. This workflow 
provides a quick, flexible, and efficient means of creating points for extracted features 
and attributes in scanned areas. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online Help. 

Step 1. Open the project 

For this tutorial, you will use the project file Extracting Point Features.vce.  

Note: The downloaded ExtractingPointFeaturesFromaPointCloud folder contains this 
PDF file and the Extracting Point Features.vce project file and project folder.  

1. In SO, select File > Open. 

2. In the Open File dialog, browse to 
..\ExtractingPointFeaturesFromaPointCloud\Extracting Point Features.vce and click 
Open. 

The project opens in the Survey Office window. It includes an imported point cloud 
in which region classification has been performed, as described later in this tutorial. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 

Step 2. Prepare for the extraction process 

Before you begin the point feature extraction process, you will import a Feature 
Definition Library (.fxl) file into the project, enabling you to map feature code attributes 
defined in the Feature Definition Library to attributes defined for the extraction type 
you select to use to create point features. You will also select a subset of scan points in 
your project point cloud from which you want to extract point features. 

1. In the SO Quick Access toolbar, select Project Settings.  

2. In the Project Settings dialog, select Feature Code Processing in the left navigation 
pane.  

3. Click the Browse button  located to the right of the Feature definition file field. 
Then, select the GlobalFeatures.fxl file and click the Open button to import the file 
into the project  
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4. When the selected FXL file displays in the Feature definition file field, click OK to 
close the Project Settings dialog. 

An Imported Files node representing the newly imported FXL file displays in the 
Project Explorer. 

  

In addition, the GlobalFeatures node displays nested beneath Feature Library 
parent node in the Project Explorer. Nested beneath GlobalFeatures node are 
numerous expanding nodes representing each of the control codes and feature 
definitions defined in the library. 
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For this project, you do not want to extract feature points from the entire point 
cloud in your project, so you will select a subset scan points with which to work. This 
will be particularly helpful later in this tutorial when you use the Automatic point 
extraction method 

5. Zoom in the Plan View as shown here. Then, using your cursor, make a rectangular 
selection as shown. 

  

6. In the SO ribbon, select Point Cloud > Regions > Keep In to display only the selected 
points in the graphic views and hide the others. 
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This would be a good time to "clean up" the view by hiding unnecessary 
information. 

7. In the SO ribbon, select Home > View > View Filter Manager.  

8. In the View Filter Manager, uncheck the following check boxes:  

 Raw Data > Azimuth 

 Raw Data > Media Folder 

 Raw Data > Total Station 

  

9. In the SO ribbon, select Home > View > 3D View and take a moment to explore the 
view. 
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Step 3. Extract point features manually 

SO supports two methods for extracting point features:  

 Manual - This method allows you to pick objects independently for extraction, one 
at a time. In this step, you will use this method to extract a Pole point feature. 

 Automatic - This method is less accurate than the manual method, but it requires 
less user input as it allows the software to automatically identify and extract at the 
same time all of the objects of the selected extraction type included in the displayed 
scan points. No manual selection is required. You will use this extraction method 
later in this tutorial.   

To extract a Pole feature point using the Manual method, follow these steps: 

1. In the SO ribbon, select Point Clouds > Deliverables >Extract Point Feature. 

In this project, the following point cloud regions have already been classified based 
on ASPRS (American Society for Photogrammetry and Remote Sensing) classes using 
the Extract Classified Point Cloud Regions command: 

 Buildings 

 Ground 

 High vegetation 

 Poles and signs 
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If the classification had not already been performed, a message would display at this 
point recommending that you classify point cloud regions prior to performing point 
feature extraction. This step is optional, but highly recommended. It helps ensure 
faster processing times and higher accuracy. And, the classified regions are saved in 
the project so the classification process needs to be performed only once, 
regardless of how many times you run the Extract Point Feature command.  

Note: See the online Help for instructions on using the Extract Classified Point 
Cloud Regions command. 

2. In the Extraction type drop-down list, select Pole to indicate that you want to 
extract a point feature for one or more poles displayed in the graphic view. 

Your selection determines the extraction attributes to which feature code attributes 
can be mapped during the extraction process. 

3. Select the Manual extraction method option. 

4. Click the Settings link (located above the Extraction type field) to display the 
Manual Pole Extraction Settings dialog. Then, select the Diameter at bottom option 
to specify that the diameter that is automatically measured at the base of the pole 
be used to populate the Diameter attribute for the pole feature. 

  

5. Click the OK button to close the Manual Pole Extraction Settings dialog.  

6. In the Extract Point Feature pane, click in the Pick a point on the pole field and 
then, in the 3D View, select a scan point on a pole for which you want to create a 
feature point, as shown here.  
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Due to the nature of point clouds, you may need to rotate the 3D View slightly to be 
sure that you have actually selected a point on the object, not a point that is in front 
of or behind it. 

A visual selection indicator displays on the light pole, verifying your selection. 
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Note: You can also make your selection using a Station View (if applicable). If 
referenced photo images are included, you can check the Virtual DR check box on 
the Station View tab to display the Pixel Picker, which enables you to select on a 
referenced photo image the location (pixel) on the object you want to select. SO 
then projects a nearby scan point onto the line-of-sight ray to help calculate the 3D 
position of the selection. If there are no nearby scan points, an appropriate error 
message is displayed and you will need to make a new selection. Note that before 
using the Virtual DR feature, it is highly recommended that you register the scans in 
your project.  

 

7. Click the Extract Pole Attributes button, or press the Enter key. 

When the extraction process is complete, the Mapped section in the Attributes 
group located at the bottom of the Extract Point Feature command pane displays a 
row for each attribute defined for the selected Extraction type (along with an 
extracted attribute value). This two-column section allows you to map a feature 
code attribute (left column) to each of the extraction attributes (right column). Since 
a feature code has not yet been entered in the Feature code field, the Select 
attribute drop-down lists are disabled and the Unmapped section of the Attributes 
group is empty. 

  

A visual extraction indicator displays in the 3D View for the selected object. The 
visual indicator, along with the values displayed in the Mapped section of the 
Attributes group, provides the feedback you need to verify that the extraction was 
accurate. 
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You could change the displayed Point ID, which will be assigned to the new point. 
The point ID will automatically increment as each subsequent point feature is 
extracted, unless you change it. Do not make any changes for this tutorial. 

Do not select a different Layer. The feature code you select in the next step will 
determine the layer on which the point is displayed and the Layer control will 
become disabled. 

Note: The Extract Point Feature command supports the creation of a point without 
assigning a feature code. In this case, you could use the Layer drop-down list to 
select the layer on which to create the new point. 

8. Click the Browse button located to the right of the Feature code field to open the 
Feature Code Editor. Then do the following: 

a. Select LP - LightPole in the GlobalFeatures.fxl list. 

b. Click the Add Code button. 

Note that this feature code supports three optional attributes. 
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Note: If you know the feature code you want to use, you do not need to use the 
Feature Code Editor to select it as you have done here. Instead, you can type the 
code directly in the Feature Code field. 

9. Click OK. 

The Feature Code Editor dialog closes and the newly selected code displays in the 
Feature code field. Attributes for the LP feature code display in the Unmapped list 
in the Attributes group.  

  

Note: If you do not enter a feature code, no feature or attributes will be assigned to 
the new point. This is an allowable alternative if you simply want to create new 
points without features. 

Default values for the Height and Diameter feature attributes assigned to the LP 
feature code in the imported Feature Definition Library are displayed in the right 
column of the Unmapped list. If you do not map these attributes to the extraction 
attributes displayed in the Mapped list, these default values will be used for the 
new point feature. The photo attribute has no default value; therefore, because this 
attribute is not required (a yellow circle displays with an attribute if it is required) 
and there is no corresponding extraction attribute, you will ignore it. 
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If a feature attribute supports the same data type as an extraction attribute (for 
example, number, integer, text, file, or other data type), the feature attribute is also 
displayed in the Select attribute drop-down list located in the left column in the 
Mapped section so that you can select it to map to the corresponding extraction 
attribute. In this case, the two extraction attributes on the right (Pole diameter and 
Pole height) support only number values. Two of the feature attributes also support 
only number values; therefore, these two feature attributes are included in the 
drop-down list for selection for each of the two extraction attributes. The non-
number feature attribute (photo) is not included in the drop-down lists. 

10. To map the Height and Diameter feature attributes to the extraction attributes in 
the Mapped list,, do the following: 

a. In the Select attribute drop-down list that corresponds to the Pole diameter 
extraction attribute, select Diameter. 

b. In the Select attribute drop-down list that corresponds to the Pole height 
extraction attribute, select Height. 

Note that the photo feature attribute is the only attribute left in the Unmapped list.  

  

If there was an extraction attribute for which there was not a corresponding feature 
attribute, you would simply leave the Select attribute drop-down list with the 
default <Unmapped> selection. 

Note: As an alternative to the mapping method described in this step, you could use 
the Map Attribute dialog to achieve the same results. See the online Help for 
additional instructions. 
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11. Click the Add button. 

The new feature point is created at the base of the light pole. The associated feature 
icon is displayed with the point in the graphic views.  

  

12. In the Project Explorer, double-click the new point 1 to view its properties, including 
its associated feature and attributes. 

Note that the new point is located on the UtilityElec layer, as specified in the feature 
code's properties. 
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Note on productivity: 

For the highest productivity when using the Manual extraction method, it is 
recommended that you extract the same types of objects in groups so that you are not 
constantly changing feature codes. For example, extract all broadleaf trees, then extract 
all coniferous trees, then extract all poles, and so on. This allows for a streamlined 
workflow in which, once the feature code has been selected and its attributes mapped, 
you can simply select an object, press the Enter key once to extract attributes (same as 
clicking the Extract Attributes button), press the Enter key a second time to add the 
new point (same as clicking the Add button), and repeat until you have extracted all of 
the point features for the specified feature code. Then you can select the next feature 
code and repeat. 

Step 4. Extract point features automatically 

In this step, you will use the Automatic extraction method to enable the software to 
automatically extract point features for all of the trees displayed in your graphic view.  

1. In the Extract Point Feature command pane, select Tree in the Extraction type drop-
down list. 

2. Select the Automatic extraction method option. 
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Note that the Pick a point field is no longer displayed. The software will pick points 
automatically on each of the Tree objects it finds. 

  

3. Click the Settings link to display the Automatic Tree Extraction Settings dialog.  

If you had selected the Manual selection method, you would have the option of 
selecting to measure the diameter of the tree trunk at the location where you click 
or at a fixed elevation above ground. Since you selected the Automatic selection 
method, only the fixed elevation option is available, which allows you to change the 
displayed elevation value if necessary. For this tutorial, you will not make any 
changes. 

  

4. Click the OK button to close the Automatic Tree Extraction Settings dialog.  

5. In the Extract Point Feature pane, click the Extract Tree Attributes button.  

The status of the extraction process is displayed in the SO Status Bar. When the 
extraction process is complete, a visual selection indicator displays on each of the 
tree objects the software has extracted. 
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The software attempts to identify and extract all of the objects matching the 
selected Extraction type in the displayed point cloud. But the selections are not 
always perfect. For example, tree extraction may be difficult if trees are crowded 
very close together. Therefore, it is important that you review the extraction 
selections to ensure they are correct. Fortunately, SO provides a number of tools to 
make your QA/QC workflow as efficient as possible. But before you do this, you will 
select the feature code you want to assign to the extracted trees and map its 
associated feature attributes to the extraction attributes. 

6. In the Feature Code field, enter BT (for the Broadleaf Tree feature type). 

The Attributes: Mapped list includes an entry for each of the attributes defined for 
the extraction type. 

The Attributes: Unmapped list includes an entry for each of the attributes defined 
for the Broadleaf Tree feature definition, along with default values. Since none of 
the attributes are required, none are flagged with a yellow "Required" circle icon 
and any of them could be ignored. 
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Using the three Select attribute drop-down lists, configure the attribute mapping as 
shown here. 

  

The Tree extraction type does not include a Photo attribute. Therefore, the Photo 
feature definition attribute cannot be mapped to the extracted tree features. Again, 
since this attribute is not required, you can ignore it. 

Note that the default Type attribute for the Broadleaf Tree feature definition is 
Aspen. Obviously, all of the selected trees in the scene are not aspen, but you will 
leave this selection for now. After creating the point features, you can change the 
Type attribute for any of them using the Properties pane. As an alternative, you 
might consider modifying or creating a feature definition that includes a generic tree 
feature code that does not include a Type attribute.  

You are now ready to perform the QA/QC workflow to ensure that all of the tree 
objects have been extracted correctly. To assist you in reviewing the selections in a 
sequential, systematic manner, a green line is displayed showing a single path that 
connects all of the extracted tree objects. Using the available controls or keyboard 
shortcuts, you can easily review each of the objects along the path and make 
changes if necessary, without losing track of which extracted tree objects you've 
reviewed and which you have not. 
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To review and edit the extracted tree objects, you can do any or all of the following, 
as necessary. (There is no need to make any changes in your tutorial project until 
the next step in this procedure.) 

 To view each of the extracted objects in sequence along the green selection 
path, click the Next or Previous button to highlight the next or previous 
selection. Or, press the Ctrl + Left Arrow or Ctrl + Right Arrow keys. 

 

To display and hide the green extraction selection path, click the Path button 

. Or, press the Ctrl + 0 (numeric keypad) keys. 

 To view any of the extracted objects independently, simply navigate to the 
object in a graphic view and click the associated selection indicator. The 
unselected selection indicators are dimmed so the that the selection is clearly 
identified. 

  

 To change the status of a highlighted object, select one of the following options. 
Or, press the Ctrl + Up Arrow or Ctrl + Down Arrow keys to toggle between the 
options. 
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Ignore - Select this option to display the selection indicator in red, indicating the 
associated object will be ignored during the actual extraction process. 

 

Mark - Select this option to display the selection indicator in white simply as a 
visual "flag". For example, you may want to mark the selection to be revisited at 
a later time or to indicate where you started or ended your review. 

 

Normal - Select this option to remove a Mark or Ignore option for a selected 
object and display its associated selection indicator in its Normal default color 
purple. 
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 To display or hide a customizable limit box around the selected object in the 

active graphic view, click the Limit Box button . Or, press the Ctrl + Space 
keys. 

 

By using the limit box to isolate the object from its surroundings in the 3D View, 
you might find it easier to verify the selection is correct. This can be especially 
helpful when, for example, you are extracting tree point features and multiple 
trees and bushes are clustered closely together.  

 To move a selection indicator horizontally or vertically to correctly align it on its 
associated object, click in the Horizontal or Vertical field and select a new 
location for the indicator. Or, type in a new coordinate. (You will try this in the 
next step.) 
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Note that you can hover your cursor over the Hover here for keyboard 
shortcuts link to display a list of applicable keyboard shortcuts 

 

Note: In addition to these guidelines, be sure to navigate the 3D View carefully from 
different perspectives and zoom levels to verify that all of the trees were accurately 
extracted. If the scene includes closely overlapping trees, tall walls or buildings, or 
other visual complications, the software can err in its selection process, as you will 
see. 

If you are reviewing the extraction selections in Automatic mode and you find a 
feature object that was not found by the extraction selection process (that is, there 
is no extraction indicator on the object), you can select the Manual option, make 
your selection, and then re-select the Automatic option to continue your review 
where you left off. 

In the following tutorial example, you can see that the selection indicator is offset 
from the actual tree trunk to which it should be associated, probably due to the fact 
that the bottom of the trunk is obscured and was not included in the scan (arrow in 
image) and there are thick bushes immediately adjacent to the tree. 

  

7. To move the selector indicator onto the correct tree object: 
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a. Use the Next button to navigate to and select the errant selection indicator, or 
manually select the indicator. 

 

b. Navigate the 3D View to provide the following perspective: 
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c. Click in the Coordinates: Horizontal field. Then, select a scan point on the tree 
trunk located adjacent to the selection indicator, as shown here. 

 

 

 

Note the selection indicator does not reach to the top of the tree. It is still using 
the tree height computed for the bush on which the errant selection indicator 
was located before moving it. To fix this, you will need to change the tree 
height. 
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d. Click in the Tree height field in the Attributes: Mapped list. Then, (1) select a 
scan point at the bottom of the trunk (as indicated by the selection indicator) 
and (2) select a scan point at a location indicating the height of the tree, as 
shown here: 

 

 

 

Feel free to review the rest of the selections and make any changes as necessary. 

8. When you are done making any changes, click the Add button. 

A new feature point is created at the base of each of the extracted tree objects. The 
associated feature icon is displayed in the graphic views.  

In addition, the new points are displayed in the Project Explorer. 



 

 

 www.spectrageospatial.com Page 26  
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Again, navigate the 3D View carefully from different perspectives and zoom levels 
to verify that each tree includes a new point at the base of its trunk. Optionally, you 
can modify or add missing attribute values for any newly created point feature in 
the point's Properties pane. 

Note: For instructions on extracting points with more than one feature code, see 
the SO Help. 
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