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About this tutorial 

Survey Office provides numerous predefined reports that typically meet most user's 
reporting needs. However, you may have a need to create a custom report that meets 
the specific needs of a particular project or client — a report that requires a custom look 
or custom data layout. In this case, you can create a custom report template using 
Microsoft® Word® that defines the type of data included in the report and the layout of 
that data, and then run that report with any project. 

In this tutorial, you will create a custom report template and then use it to run a custom 
report on data in the tutorial project. You will also modify a predefined custom report 
template. 

Notes:  
- MS Word version 2010 or later is required to make edits to a report template. 
- You cannot use the cloud-based version of Word in Microsoft® Office 365 to create 
custom reports. 
- If you need additional help at any time you are using the software, press F1 to display 
the online help. 

 

Step 1. Open the project 

For this tutorial, you will use the project file Creating Custom Reports.vce. GNSS, total 
station, and level data has already been imported into the project, and GNSS baselines 
have been processed. 

Note: The downloaded CreatingCustomReports folder contains this PDF file and the 
Creating Custom Reports.vce project file. It also contains the Tutorial Custom 
Report.docx file that you will use to create a new custom report template. 

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\CreatingCustomReports\Creating Custom 
Reports.vce and click Open. 

The project opens in the Survey Office window. 
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The project file is read-only. You can perform the tutorial steps without saving the 
project file.  

Step 2. Create a new custom report template 

In this step, you will specify properties for a new custom report template.  

1. In the Quick Access toolbar (located at the top of the SO window), select Reports > 
Create Custom Report to display the Create Custom Report dialog. 

  

2. In the Report name field, enter Tutorial Custom Report. 

This is the name you will select when you run the report in SO. You will also select to 
use this name as the title to display in the report later in this procedure. 
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3. In the Description field, enter Use for tutorial. 

This description is displayed with the report in the Report Options pane, which is 
covered later in this tutorial. 

4. In the Report source data drop-down list, select Point List. 

Each of the options in the list specifies a set of related data that can be added to 
your report. For the Tutorial Custom Report, you will be including point data. 

5. Click the Search button located to the right of the Report layout file field.  

The Open dialog displays with the the C:\ProgramData\Trimble\ReportTemplates 
folder opened. This folder contains the predefined DOCX custom report templates 
installed with SO. For this procedure, you will not select to use one these DOCX 
template files. Instead, you will use a DOCX file that was downloaded with the 
tutorial package. 

6. In the Open dialog, browse to the location where you downloaded the tutorial, 
select  ..\CreatingCustomReports\Tutorial Custom Report.docx, and click Open. 

  

7. Click Edit Layout to open Tutorial Custom Report.docx, which is a custom report 
template created specifically for this tutorial. 

8. In the Report Layout Data Fields message dialog, click OK to insert the Point List 
source data into the Tutorial Custom Report.docx template. 

The Tutorial Custom Report.docx document opens in MS Word.  
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Note: The Create Custom Report dialog will remain open while you edit the report 
template in Word. When you are done making edits in Word, you will return to this 
dialog to save the template in SO. 

Step 3. Edit the new custom report template 

In this step you will add Point List data fields to the Word document, which has already 
been formatted with headings, labels, and tables to support the data fields you want to 
add to the report. You can, as necessary, create your own Word document with the look 
and layout you desire for the resulting report.  

Notes:  
- MS Word version 2010 or later is required to make edits to a report template. 
- You cannot use the cloud-based version of Word in Microsoft® Office 365 to create 
custom reports. 
- If you open a DOCX report template directly from an Explorer window or the Word 
application, the Report Layout Data Fields dialog will not display and you will be unable 
to make data field edits in the template. To display the Report Layout Data Files dialog 
with the template in Word, you must open the template using the the Edit Layout 
button in SO. 

The Tutorial Custom Report.docx file is read-only, so you will need to start by saving the 
file with a new name. 

1. In MS Word, do the following: 

a. Select File >Save As and click the Browse button.  

b. In the Save As dialog, save the file to the  ..\CreatingCustomReports folder with 
a new name: Tutorial Custom Report - Copy.docx. 

c. Click Save. 
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2. In MS Word, click the Show/Hide paragraph icon  in the tool bar to display 
formatting marks and hidden field text in the document. 

  

 

  

Seeing the formatting marks should make it easier to perform the formatting tasks 
described in this procedure.  

The following image shows the various components of the report template 
document. 
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Key: 

1. These are the headings, labels, and tables that have already been inserted 
into the document. When creating or editing a report template, you can use 
any of the formatting features in Word to provide the look and feel you 
want in the final report. 

2. This is the Report Layout Data Fields pane. It displays all of the data fields 
available with the selected Report source, any of which you can select to 
add to the report template. Data fields are grouped in a "tree" type 
organization with expanding folder nodes. 

3. These are "hidden" Field Mapping data fields that are required for the 
template. You can ignore these fields; you will not interact with them. Note 

that you can hide the fields by clicking the Show/Hide paragraph icon . 

To add data fields to the report template, you can click and drag the field from the 
Report Layout Data Fields pane to any location in your document. Or, you can 
select the data field in the Report Layout Data Fields pane and click the Insert 
button. 

3. In the Report Layout Data Fields pane, expand StandardHeaderInfo > 
CompanyInformation. Then click and drag the CompanyName data field to the right 
of the static text Company name in the template. 

The data field displays showing the data field name and placeholder text. 
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When the report is generated, the company name specified in the project (Project 
Settings > General Information > Company Information) will display. 

4. Repeat this procedure to insert the StandardHeaderInfo > ProjectInformation > 
ProjectTitle and StandardFooterInfo > Current Date data fields into the template. 

When you are done, placeholder text displays in the template at the locations 
where you inserted the data fields. 

  

5. Insert the following data fields into the empty second row in the Coordinate System 
table: 

 StandardHeaderInfo > CoordinateSystem > Name 

 StandardHeaderInfo > CoordinateSystem > Datum 

 StandardHeaderInfo > CoordinateSystem > Zone 

 StandardHeaderInfo > CoordinateSystem > Geoid 

  

Note: To remove a data field and its placeholder text from the template, simply 
select it and press the Delete key twice. Or, click the Remove button in the Report 
Layout Data Fields pane.  

6. Insert the following data fields into the empty second row in the Points table: 

 Points > Point > PointID 
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 Points > Point > Global > Longitude 

 Points > Point > Global > Latitude 

 Points > Point > Global > EllipsHeight 

  

Next you will specify to display all of the points in the project, along with their 
coordinates, in the same table. 

7. To specify that additional point rows be created as necessary in the report, do the 
following: 

a. Select the PointID data field in the table. 

  

b. In the Report Layout Data Fields pane, click the Property button to display the 
Property pane for the selected instance of the data field. 

c. Check the Increase rows for new record check box. 

Note that you also have the option to create a new table in the report for each 
point record by checking the Insert table for new record check box. 

  

d. Click OK. 

Although you do not see a change in the template, additional rows will be created 
as necessary when you generate the report with project data. 

8. Insert the following data fields into the empty cells in the second row in the Feature 
Codes table: 

 Points > Point > PointID (first and third column) 

 Points > Point > FeatureCode > FeatureCode (second and fourth column) 



 

 

 www.spectrageospatial.com Page 10  
 

  

Note that each time you insert a new instance of a data field into the template, the 
number in parenthesis to the right of the data field in the Report Layout Data Fields 
pane increments by one, giving you an ongoing tally of how often the field is being 
used. You can see that the PointID data field has been inserted three times. 

  

Also note that each instance of a data field is displayed in the Layout control list 
when any of the instances is selected in the template. Any options selected for an 
instance (in the Property dialog) are also displayed in the list. This allows you to 
select multiple instances of a data field and apply the same property to all of them at 
the same time using the Property dialog. In the following example, an instance of a 
PointID data field has been selected in the template. The three instances of the 
PointID data field are displayed in the Layout control list, and you can see that the 
first instance has the Increase rows option selected. 

  

Unlike the Points table, where you set up a single row and then specified that rows 
be added as necessary to accommodate all of the point records, for this table you 
will create a specific number of rows so that the records can sort downward and 
then across using the Repeated Order Number option in the Property pane. 

Repeated Order Number option not selected: 

  

Repeated Order Number option selected: 

  

9. To add rows to the Feature Codes table, do the following : 
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a. Click in the template to the immediate left of the second row in the Feature 
Codes table to select the row. Or, click and drag to select the row. 

  

b. Right-click and press Ctrl + C to copy the row, including the inserted data fields. 

c. Click to the left of the paragraph marker immediately following the table and 
press Ctrl + V to paste the copied row immediately following the first row. 

  

d. Continue to add 12 additional rows to the table (that is, continue to press Ctrl + 
V) for a total of 14 rows. 

e. The table will now support 28 PointID/FeatureCode records: up to 14 in each of 
two columns. 

10. To apply the Repeated Order Number option to the data fields in the table, do the 
following: 

a. Either click and drag, or use Shift + click, to select the first two columns in the 
second through fourteenth rows. 

  

b. Click the Property button in the Report Layout Data Fields pane to display the 
Property dialog. 

c. Ensure the first two check boxes are not selected and select 1 in the Repeated 
Order Number drop-down list.  
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d. Click OK. 

e. Select the last two columns in the second through fourteenth rows, click the 
Property button in the Report Layout Data Fields pane and select 2 in the 
Repeated Order Number drop-down list in the Property dialog. Then click OK. 

  

Your report template is complete. 

11. Click Ok in the Report Layout Data Fields pane. 

MS Word closes. 

The new Word template file name Tutorial Custom Report - Copy.docx displays in 
the Report layout file field in the Create Custom Report dialog in <Survey Office. 

You are now ready to run the new custom report. 

 

Step 4. Run the new custom report 

1. In the Create Custom Report dialog in Survey Office, click OK. 

The new report template is added to the report lists displayed in SO.  

There are several ways to run a report. For this procedure, you will use the Report 
Options pane. 
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2. In the Quick Access toolbar, select Reports > Report Options to display the Report 
Options pane. 

  

3. In the Reports list, select Tutorial Custom Report and click the Show Report button 
located in the Report Options pane tool bar. 

The new custom report opens in MS Word, showing the project data. 

 

Note that additional rows were added to the Points table to support all of the points 
in the project. Note too that the records in the Feature Codes table run down and 
then across, as designed. 
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Next, you will modify a predefined custom report template. 

Step 5. Create a predefined custom report template 

In this step, you will specify properties for a new custom report template based on one 
of the predefined MS Word report template installed with Survey Office in 
C:\ProgramData\Trimble\ReportTemplates. The predefined report templates replicate 
the default RDLC templates typically used to generate SO reports. Your intent in this 
tutorial is to add a point/feature code table to a predefined Baseline Processing Report 
template. 

1. In the Quick Access toolbar, select Reports > Create Custom Report to display the 
Create Custom Report dialog. 

  

2. In the Report name field, enter Tutorial Custom Report 2. 

This is the name you will select when you run the report in SO. You will also select to 
use this name as the title to display in the report later in this procedure. 
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3. In the Description field, enter Use for tutorial. 

This description is displayed with the report in the Report Options pane. 

4. In the Report source data drop-down list, select Baseline Processing Report. 

5. Click the Search button located to the right of the Report layout file field.  

The Open dialog displays with the C:\ProgramData\Trimble\ReportTemplates folder 
open. 

6. In the Open dialog, select Custom Baseline Processing Report.docx and click Open. 

  

7. Click Edit Layout to open Custom Baseline Processing Report.docx. 

The Custom Baseline Processing Report.docx document opens in MS Word.   
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Note: The Create Custom Report dialog will remain open while you edit the report 
template in Word. When you are done making edits in Word, you will return to this 
dialog to save the template in SO. 

 

Step 6. Edit the predefined custom report template 

In this step you will add Point List data fields to the predefined Custom Baseline 
Processing Report.docx template. 

Notes:  
- MS Word version 2010 or later is required to make edits to a report template. 
- You cannot use the cloud-based version of Word in Microsoft® Office 365 to create 
custom reports. 
- If you open a DOCX report template directly from an Explorer window or the Word 
application, the Report Layout Data Fields dialog will not display and you will be unable 
to make data field edits in the template. To display the Report Layout Data Files dialog 
with the template in Word, you must open the template using the the Edit Layout 
button in SO. 

The Custom Baseline Processing Report.docx file is read-only, so you will need to start by 
saving the file with a new name. 
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1. In MS Word, do the following: 

a. Select File >Save As and click the Browse button.  

b. In the Save As dialog, save the file to the tutorial ..\CreatingCustomReports 
folder with a new name: Custom Baseline Processing Report - Tutorial.docx. 

You could save the file to the default C:\ProgramData\Trimble\ReportTemplates 
folder, but it is probably better not to "clutter" that folder with this new tutorial 
report template. 

c. Click Save. 

2. If a Microsoft Word message dialog displays prompting you to upgrade to the 
newest file format, click OK. 

3. In MS Word, click the Show/Hide paragraph icon  in the tool bar to display 
formatting marks and hidden field text in the document. 

You can now edit the report template by changing the look and layout as necessary. 
For example, you can move tables, remove tables, remove data fields, change fonts 
and sizes, and so on. For this tutorial, you will add a FeatureCode table to the end of 
the report. 

4. Scroll to the end of the template (but preceding the "hidden" Field Mapping data 
fields) and click to insert the cursor to the immediate left of the paragraph marker 
following the "Acceptance Criteria" table, as shown here. Then press the Enter key 
four times to insert four new paragraph markers preceding the paragraph. 

  

  

5. To insert the heading for the new table, do the following: 

a. Click to insert the cursor to the immediate left of the second paragraph marker 
following the "Acceptance Criteria" table and type Feature Codes. 
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b. Select the new heading text and then select Arial, Bold, 10 pts in the pop-up 
formatting toolbar (or select Home > Font in the Word ribbon). 

   

c. With the table heading text still selected, click Home > Paragraph > Center to 
center it in the report. 

  

 

  

6. Click to insert the cursor to the immediate left of the first paragraph marker 
following the new table heading and do the following to insert a new table: 

a. In the Word ribbon, select Insert > Tables > Table and select to create a two-
column table with two rows. 
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b. In the first column in the first row, type Point ID for the column heading. 

c. Select the new column heading text and change the font to Arial, Bold, 9 pt in 
the pop-up formatting toolbar. Also, select to center the column heading in the 
column. 

  

d. Repeat these steps to add the column heading Feature Code to the second 
column. 

  

You are now ready to insert data fields into the new table 

7. In the Report Layout Data Fields pane, select Point List (Sub) in the Report source 
drop-down list. 
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This is the same data source you used to create the previous template. Here, it is 
included as a "sub-report" data source for the primary Baseline Processing Report 
data source, allowing you to insert additional point/feature-related data fields into 
the report template. 

8. In the Report Layout Data Fields message window, click OK to insert the Point List 
source data into the Custom Baseline Processing Report - Tutorial.docx template. 

The data fields included in the Point List (Sub) report source are represented by a 
closed expandable node in the Data fields list. 

  

9. Using the Data fields list, insert the following data fields into the empty first and 
second column in the second row in the table. 

 Points > Point > PointID (first column) 

 Points > Point > FeatureCode > FeatureCode (second column) 

  

10. Click to the immediate left of the second row to select it. Then change the font to 
Ariel, 8 pts (not bold) in the pop-up toolbar.  

This will apply the correct font style to the data in the actual report. 

11. To specify that additional rows be created as necessary in the report, do the 
following: 

a. Select the PointID data field in the table. 

b. In the Report Layout Data Fields pane, click the Property button to display the 
Property pane for the selected instance of the data field. 

c. Click the Increase rows for new record check box. 
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d. Click OK. 

Miscellaneous notes: 

 If you scroll up to the previous table in the report template (Acceptance 
Criteria), you can see two blue data field placeholders in the first row.  

  

If you click on either of the blue placeholders, you can see that it is actually an 
image frame representing a data field that references a graphic file, which will 
display in the final report. 

Template: 

  

Actual report: 

 

Note that you can change the size of the image in the actual report by checking 
the Stretch image to fit the control check box in the Property dialog and 
resizing the image frame in the template. 

 If you create an empty table with multiple columns, you can drag a folder node 
from the Data fields list into the first column in the row, causing each of the 
data fields nested beneath the folder node (including those in subfolders) to be 
inserted into each of the columns in the row automatically, up to the limits of 
the row. For example, if you insert a folder node that contains five data fields 
into a table row with four columns, each of the first four data fields in the folder 
will be inserted into each of the columns in the row. The fourth data field will be 
ignored. 
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 If a folder in the Data fields list includes a red plus symbol, it indicates that the 
first data field in the folder is a parent field and all data fields nested beneath it 
in the folder and all subfolders are child fields.  

  

The data in the child fields is dependent on the parent field. For example, a 
Point field is a parent field that includes numerous child fields, including 
FeatureCode, Attributes, Northing, Easting, Elevation, and additional property 

fields for the point. You can insert a parent/child folder ( ) into a template 
table row, which, in turn, automatically adds the folder's parent field to the first 
column, followed by the child fields contained in the folder and subfolders in 
each of the subsequent columns, up to the limits of the row.  

For this tutorial, your report template is complete. 

12. Click OK in the Report Layout Data Fields pane. 

MS Word closes. 

You are now ready to run the newly edited predefined report. 

Step 7. Run the edited predefined custom report 

For this step, you will use a different method to run the report than you used in the step 
4. 

1. In the Create Custom Report dialog, click OK. 

The new report template is added to the report lists displayed in SO. 

2. In the Quick Access toolbar, select Reports > More Reports. 

  

3. In the More Reports dialog, select Tutorial Custom Report 2 and click OK. 

The new report opens in MS Word, showing the project data. 
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Go to the end of the report to see the new Feature Code table you added to the 
report template. 

  

Note: To edit an existing report template, select it in the Report Options pane and 
click the Edit Custom Report button to display the Edit Custom Report dialog. 

This completes the tutorial. 
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