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About this tutorial 

Survey Office (SO) is designed to help you create high-accuracy surfaces for stakeout 
using Trimble Access or other positioning systems. Your data for these models may 
come in any number of formats: paper drawings that describe what to construct, files 
with 2D or 3D surveys or designs, or some combination of all three.  

SO facilitates the management of data for multiple field crews operating on a job site. 
You can import, review, and analyze digital designs, and then assign, manage, and track 
that information through the lifetime of a construction project. 

This tutorial shows you the power and flexibility of SO by guiding you through a 
workflow for changing design data depicting the final grade into intermediate surfaces 
and objects required to construct the final design. 

After working through this tutorial, you will be familiar with the following tasks: 

 Reviewing and modifying the layers your objects reside on, and deleting unused 
layers 

 Running a cleanup on your data 

 Creating missing data and completing partial data 

 Creating new objects by copying and offsetting from existing ones 

 Moving, rotating, and scaling objects 

 Elevating lines using various commands 

 Checking the elevations of lines you elevated 

 Creating a surface from contour lines 

 

Step 1. Open the project 

For this tutorial, you will use the project file Performing Data Prep.vce. This project 
contains a site plan drawing. 

Note: The downloaded PerformingDataPrep folder contains this PDF file and the 
Performing Data Prep.vce project file.  

1. In SO, select File > Open. 

2. In the Open File dialog, browse to ..\PerformingDataPrep\Performing Data Prep.vce 
and click Open. 

The project opens in the Survey Office window.  
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The project file is read-only. You can perform the tutorial steps without saving the 
project file. However, if you are interrupted while performing the tutorial, you can save 
it with a new name by selecting File > Save Project As. Then, you can re-open the 
project to continue the tutorial at a later time. 

Step 2. Review objects by layer 

Your goal in doing data preparation is to create high-accuracy surfaces for stakeout, 
machine control, or takeoff calculations by making your data as complete and accurate 
as possible. The following procedures will help you learn useful ways to clean up and 
prepare your data for any of those surfaces. 

As you begin data preparation, make sure that your data is well organized by layer. You 
can create and delete individual layers, rename layers, purge all empty layers, and 
review objects by choosing their layer. Layer properties allow you to change layer colors 
and line styles to help you distinguish more easily between data on different layers. 

1. In the Survey Office ribbon, select Home > View > View Filter Manager. 
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2. In the the View Filter Manager do the following: 

a. Click the Zoom extents icon on the toolbar at the top of the View Filter 
Manager (1 in the image below) to enter the zoom extents when the filter 
changes mode. 

b. Filter the view by right-clicking the name of any layer and selecting View Only 
This from the context menu.  

All of the other check boxes in the group are automatically unchecked so that 
only the selected layer is visible. 

Another way to turn individual layers on or off to better understand what data 
is on each layer is to isolate layers. 

c. Click the Isolate Layer icon on the toolbar (2 below). 

d. Click the names of various layers to see the data that resides on them in the 
view.  

Only objects on the selected layer are visible. Review each layer to see how your 
project data is organized. 

Notes:  
- When in Isolate Layer mode, you may find it faster to use the up and down arrow 
keys to move through the layer list.  
- Press [Spacebar] to check or uncheck the box for any layer. All checked layers will 
be visible in the view filter when you exit the Isolate mode. 

e. Specifically, select the ROADS layer and notice that one of the building pad 
outlines is incorrectly assigned to it (3 below).  

  

You will need to move this object to the Pads layer. 

3. In the Plan View, select the pad outline. 
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4. Click the Zoom extents icon and Isolate Layer icon in the View Filter Manager 
toolbar to exit those modes. Then check the Layers check box to show all of your 
layered data. 

5. Ensure the pad outline is still selected, then right-click in the Plan View and select 
Properties from the context menu. 

  

6. In the Properties pane, click in the Layer drop-down list and select Pads as the new 
layer. 

In your review of the layers, the Defpoints layer appeared empty, so you will delete 
it from the project. 

7. Right-click the Defpoints layer in the View Filter Manager and select Layer Manager. 

8. In the Layer Manager dialog, click the red Delete icon located at the right end of the 
Defpoints layer. 

 

Note: Typically, you want to make sure that all of your objects are on the correct 
layers before you delete empty layers. Otherwise, you may have to recreate layers 
that you thought were unneeded. You will automatically remove all remaining 
empty layers in the next procedure. 

9. In the Layer Manager pane, select each layer to review its name, color, and line 
style. 



 

 

 www.spectrageospatial.com Page 6  
 

In the Layer Manager dialog, you can rename any layers that are unclear so that 
their names make sense and indicate what type of data is on the layer. Try to keep 
names as short and straightforward as possible so that when you send data out to a 
controller or machine in the field, the device operator can readily identify each 
object. For example, you might add prefixes such as OG or FD to distinguish layers 
that contain original ground data from layers that include finished design data. You 
can also edit any of the other attributes as necessary. 

Note: If you select a layer color that is the same as your graphic view's background 
color, the inverse of that color is used in the view. If you want to hide a layer, do not 
use color; use the View Filter Manager. 

10. Close the Layer Manager dialog and Properties pane. 

 

Step 3. Clean up data 

Now that you are done reviewing the initial data, you can automatically optimize it by 
removing unneeded objects, converting CAD lines into linestrings, and joining lines. You 
can opt to clean up only a portion of your data by selecting it; however, for this exercise, 
you will run the cleanup on all of the data in your project. 

1. In the SO ribbon, select Data Prep > CAD > Project Cleanup. 

  

2. In the Project Cleanup dialog, do the following: 

a. Review the default settings.  

Although you may correctly suspect that some of them do not apply to your 
data, you may want to leave them checked just to be sure. If you ever change 
the settings and need to restore the defaults, you can click the Defaults button. 

In the following steps you will change some specific default values. 

b. To simplify your linear data, check the Filter line vertices check box. 
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c. In the Circle filtering radius field, enter 0.002.  

This specifies the horizontal distance that a node between two segments must 
deviate from tangent to be retained. Setting this tolerance lower will retain 
more nodes. 

d. Check the Set elevation outside range to undefined check box. 

e. Since you do not know the elevation range of your data, click the Scan for 
Elevation Range button.  

The results display in the Minimum elevation and Maximum elevation fields. 

f. Uncheck the Set elevation outside range to undefined check box.  

This would have let you specify an elevation range outside of which object's 
elevation would be set to zero. In the Minimum elevation and Maximum 
elevation fields, you can see that all of your data is in a realistic range, so there 
is no need for this option 

  

g. Click the Apply button to clean your data based on the enabled options.  

h. Review the results in the Status box.  

  

You can see that a number of unused styles, objects, and layers were removed, 
and that your lines were simplified.  

Besides simplifying your data, cleaning up your project makes the file smaller 
and faster to work with. 

i. Click the Close button. 
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Step 4. Create points from spot elevations 

One of the first steps in data prep is to ensure that your data is complete and in its most 
usable form. For example, to prepare for elevating 2D lines so you can make a surface 
out of them, you can create 3D points from a variety of elevation spot indicators and 
then use these points to elevate the lines. 

To easily identify which lines have been elevated, you can open a 3D View alongside the 
Plan View and set your zero-elevation data for both views to an alternate color in the 
View Filter Manager before you begin. 

1. In the View Filter Manager, click the Display Options tab located at the bottom of 
the pane and select the Display in alternate color option. Then select Gray in the 
Alternate color drop-down list. 

  

2. In the SO ribbon, select Home > View > 3D View. 

3. Right-click on the 3D View tab header and select New Horizontal Tab Group so you 
can see both the Plan View and 3D View at the same time. 

4. Click the mouse wheel in the 3D View and drag the mouse until you have an 
isometric view, as shown below. 
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5. To hide the grid lines, as shown above, click on the Plan View tab header and then, 
in the Status bar (located at the bottom of the SO window), select Toggle Gridlines. 

6. Click the Plan View and use your mouse wheel to zoom in to one of the spot 
elevations near a road centerline as shown here. 

  

7. In the SO ribbon, select Data Prep > Elevate > Create Points from Spot Elevations. 

For the first three settings in the Create Points from Spot Elevations pane, you need 
to determine the nature of the spot elevation. 
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8. Click the View Filter Manager tab heading to take the focus off the Create Points 
from Spot Elevations pane and change to a selection cursor. 

9. Zoom in and click on each of the three CAD text objects that identify the spot 
elevation — label abbreviation (1 below), elevation (2), spot location indicator plus 
sign (3) — to verify they are separate objects. 

  

10. Click a blank space in the view to deselect everything. 

11. In the Create Points from Spot Elevations pane, do the following: 

a. Based on what you have determined about the spot elevation, uncheck the Spot 
indicator is part of the elevation label check box. 

b. In the Spot indicator drop-down list, select Text plus sign. 

c. Verify the Spot and elevation are in same block check box is unchecked since 
the three objects were not grouped together as a block. 

d. Since the spot elevations are not relative to a common base elevation, do not 
change the default value 0.000 in the Base elevation field.  

e. In the Layer drop-down list, select Points as the layer on which to create the 
new points. 

f. Since there are no other points in your project, do not change the default value 
1 in the Starting point number field as the point ID for the first point created.  

Subsequent points will be numbered sequentially from the starting number. 

g. Leave the Feature code field empty. 
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h. Click the Options button located next to the Spot elevations field, and select 
Select by Layer from the pop-up menu to display the Select by Layer pane. 

  

This will make it easy to select all of the objects that are part of spot elevation 
indicators in your project. 

12. In the Plan View, click any part of the spot elevation (text, numerals, or indicator) to 
select the appropriate layer in the Select by Layer list (in this case, layer P-Grade 
TXT). Then click the Close button. 

Notice that 122 objects (and all three parts of each spot elevation) on the P-Grade 
TXT layer are now selected. 

  

13. In the Create Points from Spot Elevations pane, click the Apply button. 

14. In the Projection Definition dialog, click OK.  

Nine points are created at the locations of the spot elevation indicators. The points 
inherit the elevations of the text, and appear in the graphic views and Project 
Explorer. 
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15. In the Create Points from Spot Elevations pane, click Close.  

 

Step 5. Copy and offset objects 

1. With the focus in the Plan View, use your mouse wheel to zoom in on the site as 
shown here. 

  

Notice that there is one rectangle (representing a building pad) that is missing from 
your data set (1 below). You will create a copy of an existing pad and position it 
where the one is missing. 

  

2. In the SO ribbon, select CAD > Edit > Copy Objects. 
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3. In the Copy Objects pane, do the following: 

a. Click in the Objects to copy field and pick the pad outline labeled 2 in the image 
above. 

  

b. Leave the Relayer copied objects check box unchecked to inherit the layer from 
the selected pad. 

c. Click Apply.  

The Move Objects pane displays. 

  

4. In he Move Objects pane, do the following: 

a. Click in the From field and then zoom in on the Plan View and pick the corner of 
the pad labeled 3 in the earlier figure and as shown here.  
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b. Click in the To field and then pick the corner of the pad labeled 4 in the earlier 
figure and as shown here.  

  

Picking these two points moves the pad copy the same relative distance and 
direction as the existing pads. 

Your data in the Plan View should now look like this. 

  

c. Click Close and then de-select the pad line. 
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Next, you will create a back-of-curb line offset from the existing edge of pavement 
lines. 

5. In the Plan View, zoom in to the lines at the edge of the road near the bottom of the 
data, as shown here. 

  

6. In the SO ribbon, select CAD > Edit > Offset Line. 

  

7. In the Offset Line pane, do the following: 

a. Click in the Line to offset field and then pick the outer line in the Plan View as 
shown here. 
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b. Typically, the Name field is filled with the name of the original line. Since the 
original line is unnamed, type Back of curb in the field. 

c. Click in the Layer drop-down list and then click the line highlighted in the Plan 
View again to select its layer: Roads. 

d. In the Offset distance field, type 1.0. 

e. Click in the Side to offset box and click a location to the left of the selected line 
in the Plan View.  

Based on the direction of the line, Right displays in the field. 

f. Leave the Vertical offset at 0.00, and click Apply to create the offset line.  

The new offset line displays in the Plan View and 3D View. 

  

g. Click Close. 
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You can use this same process to create additional back-of-curb lines around other 
parts of the road where they are missing. However, for this tutorial, that will not be 
necessary. 

Step 6. Move objects and create a polyline 

As long as you are adding new data, there is one more object to fix. Notice the building 
pad that is not closed in the image below: 

  

Based on an updated design from the site planners, you need to move the building pad 
above the broken pad to the northwest and complete the broken pad line by drawing a 
polyline. 

1. In the SO ribbon, select CAD > Edit > Move Objects. 

  

2. In the Move Objects pane, do the following: 

a. If any of the three Settings check boxes are checked, uncheck them. 
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Although these options can be very useful, you will not use any of them for this 
step. You will be moving the pad a specific, relative distance without using the 
Plan View. 

b. Click in the Objects to move box, and select the pad shown in the image below. 

  

c. Click in the From field, and the click any point on the selected pad line to specify 
the From point. 

d. In the To field, type: @-10,@12 

e. Click Apply to move the pad 10 feet west and 12 feet north, relative to its 
current position. 

  

f. Click Close. 

Next you will close the broken line in the second pad (2 in the figure above) using a 
polyline. 

3. In the SO ribbon, select CAD > Lines > Create Polyline. 
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4. In the Create Polyline pane, do the following: 

a. None of your lines are named, so you can leave the Name box blank.  

b. In the Layer drop-down list, select Pads as the layer on which you want the 
polyline to reside. 

c. Click in the Elevation field. Then, in the Plan View, click the elevation text within 
the broken pad line to specify the polyline's elevation: 374.140 

  

d. Leave the Automatically close by connecting ends list set to Never. 

e. In the Method to Add Points group, select the Specify individual points option 
to pick the start and end point for each segment in the polyline. 

f. Click in the Next point field, and then select the end of the line on the left as 
shown here. 
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A coordinate displays in the Next point field. 

g. Right-click in the Next point field and select Intersection > Intersection of 
Segments from the context menu to display the Intersection of Segments pane. 

  

This snap will let you draw from one of the existing segment's end points to the 
point where it would intersect with the other existing segment. 

5. In the Intersection of Segments pane, do the following: 

a. Click in the Line segment 1 field and then click anywhere on the left broken pad 
linestring to select it. 

The cursor automatically moves to the Line segment 2 field. 

b. Click anywhere on the right broken pad linestring to make your selection in the 
the Line segment 2 field. 

The first segment of the polyline is drawn to the intersection point of the two 
lines. 
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The Intersection of Segments pane closes and the Create Polyline pane displays. 

6. In the the Create Polyline pane, do the following: 

a. Click in the Next point field and then click the remaining end point to finish the 
polyline and close the pad line. 

  

b. Click Close.  

The two pads should now look like this: 

  

7. To join the new polyline with the pad line, in the SO ribbon select CAD > Edit > Join 
Lines. 
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8. In the Join Lines pane, do the following: 

a. Select the Two lines option. 

b. Click in the Base line field and then select the existing pad line. 

  

c. Click in the Line to join field and then select the new polyline you created. 

  

The lines are joined creating a single linestring for the pad. 
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d. Click Close. 

 

Step 7. Transform objects 

Earlier, you moved an object. You can also transform objects by moving, rotating, and 
scaling them in one operation. The three transformations are done in this order:  

1. Move 

2. Rotate 

3. Scale 

Dependent objects, such as surfaces, are updated when you transform objects, although 
points with control quality or local / global coordinates (in latitude and longitude) 
cannot be moved; only points defined as grid-only during import or creation can be 
moved or elevated. 

In this step you will move, rotate, and scale another of the pad outlines that the site 
engineers have changed. 

1. In the SO ribbon, select CAD > Edit > Move/Rotate/Scale Objects.  
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2. In the Move/Rotate/Scale Objects pane, do the following: 

a. Click in the Objects to move field, and then pick the pad line shown in the image 
below. 

  

b. Right-click in the From box and select Centroid to use the center of the pad's 
area as the rotation and scaling point. 

The Centroid Snap pane displays. 

  

c. Click in the Select object field, and then select the same pad in the Plan View. 

The Centroid Snap pane closes and the Move/Rotate/Scale Objects pane 
displays with the From field populated. 

d. Because you want to rotate and scale the pad in its current location, copy the 
value in the From field and paste it into the To field. 

Since you are doing a 2D planar transformation, the Delta elevation field is 
disabled. 

e. Based on the pad redesign, in the Rotation angle field type 20. 

f. To make the pad the same size as the others on the site, in the Horizontal scale 
field type 1.33333 for the factor by which to resize it. 

g. Click Apply to transform the object. Then click Close. 

Your pad outline should now look like this: 
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Step 8. Elevate contour lines 

Now you are ready to elevate many of the lines in your data so you can create a surface 
from them. You will start by using in-line elevation labels to quickly elevate 2D lines that 
represent topographic contours. The elevation is derived from the text of the label.  

1. In the SO ribbon, select Data Prep > Elevate > Contours by Label. 

  

2. In the Elevate Contours by Label pane, do the following: 

a. Click the Options button and choose Select by Layer from the context menu to 
display the Select by Layer pane. 

b. If the Pads layer is selected in the Select by Layer pane, uncheck the check box.  

c. Check the check boxes for the P-Grade 2C, P-Grade 10C, and P-Grade TXT layers. 
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d. Click the Close button.  

The Elevate Contours by Label pane displays. The Contour lines and elevation 
labels box displays the number of objects selected. 

  

e. In the Elevate Contours by Label pane, click the Apply button. 

A message displays indicating that 87 of the contour lines were elevated based 
on their labels. 

 

f. Click the Close button. 

3. Click a blank space in a graphic view to de-select everything. 

Now your data in the 3D View should look like this: 



 

 

 www.spectrageospatial.com Page 27  
 

  

You can quickly elevate many of the remaining contour lines by crossing them with a 
line that applies elevations based on a specified starting elevation, increment 
direction, and contour interval.  

4. In the SO ribbon, select Data Prep > Elevate > Contours by Crossing. 

  

If the Automatic mode is selected in the Elevate Contours by Crossing pane, you 
can draw across two or more elevated lines to specify that the contour interval, 
increment direction, and beginning elevation of the unelevated lines around them 
are automatically computed. At least two of the crossed lines must have different 
elevations from which the slope direction and interval can be determined.  

Note: The Contour interval, Increment direction, and Beginning elevation controls 
are disabled when the Automatic mode is selected. 

5. Since some of the lines already have elevations assigned from the previous 
command, verify that the Automatic check box is checked in the Elevate Contours 
by Crossing pane. 

6. To avoid crossing lines that are not contours, and still be able to view elevation 
labels, select only the following layers in the View Filter Manager: 

 P-Grade 10C  

 P-Grade 2C  
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 P-Grade TXT 

 SPOTTXT  

As necessary during this workflow, you can toggle between viewing just these layers 
as you create crossing lines, and all layers as you attempt to identify related series 
of contour lines. 

7. In the Plan View, find a series of contour lines where some are elevated and some 
are not, such as on the upper-left (northwest) corner of the site. 

  

8. In the Elevate Contours by Crossing pane, click in the From field. Then click a 
location in the Plan View on one side of the series of contour lines (as shown below) 
to specify the beginning of the crossing line. 

  

The selected coordinate is displayed in the From field and the cursor moves to the 
To field. 

9. Click a location in the Plan View on the other side of the series of contour lines (as 
shown below) to specify the end of the crossing line. 
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This coordinate is displayed in the From point after you make your selection and the 
elevations are applied. 

Notice how the gray contour lines change color in the Plan View and 3D View when 
the elevation is applied. You can also see that they have been elevated in the 3D 
View.  
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10. Find other series of contour lines where two or more are elevated and some are 
not, and repeat this procedure for each.  

Note: For this tutorial, it is not necessary that you elevate every contour line. In 
addition, your screen images may not match exactly the images shown here. The 
intent is that you at least obtain a basic understanding of the workflow and the tools 
at your disposal to perform the elevations. 

When selecting contour lines to elevate, avoid elevating the lines shown here. You 
will use a different method to elevate these later in this procedure. 

  

11. For areas in which there is only one elevated contour line (or one elevation label) in 
a series, do the following: 

a. Uncheck the Automatic check box. 

b. Because the labeled contours indicate elevation increments of 2, type 2 in the 
Contour interval field. 

c. Looking at the trend of the lines you need to elevate, specify whether you want 
the elevations to increase or decrease from the first line crossed by selecting an 
Increment direction. 

d. Click in the Beginning elevation field, and then click an elevated line or label in 
the Plan View to specify that the elevation of the selected line will be used to 
compute the elevation of each line you cross. 

For example, if the only labeled/elevated contour line to be crossed shows an 
elevation of 364 and the next contour line is uphill, specify the contour interval 
as 2.0, set the increment direction to Up, and select the line for the beginning 
elevation. Then cross all of the lines in the uphill direction to elevate them. 
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e. Find other series of contour lines where only one or more are elevated and rest 
are not, and repeat this procedure for each. 

Note: Again, for this tutorial, it is not necessary that you elevate every contour line 
correctly. Elevate as many as you feel comfortable with so that you at least 
understand the workflow and how to use the tool. 

12. Work your way around the job site, elevating as many contour lines by crossing as 
possible (or as many as you are comfortable doing). Keep in mind the following: 

 The more care you take in this process, the more accurate your results will be.  

 If you are not sure about a series of lines, do not elevate them yet. There are 
other tools you can use. 

 Try to work across series of lines in small areas so you are not skipping 
elevations in adjacent areas.  

 Be wary of contours that double back on themselves or are broken by gaps or 
other lines.  

 Zoom out periodically to try to understand the general trend of the topography. 
Display and hide layers as necessary. 

 You might miss contours because of gaps or someone might have deleted some, 
so the sequence is wrong.  

 Go only one direction (up or down) in one process.  

 Watch out for "benches" where two contours have the same elevation.  

 If you resume using your method of crossing two elevated lines to elevate 
nearby lines, remember to recheck the Automatic check box. 

 If you need to determine the elevation of a line that is not labeled, select Data > 
Explore > Explore Object and select the line. The elevation of the line appears 
next to the cursor (annotated as E:).  

Tip: Check your 3D View periodically to find contours that you have missed, and to 
ensure that you are elevating them correctly. How carefully you want to prepare 
your data for the purpose of this tutorial is up to you, but you should be very careful 
when using your own real job site data. 
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13. When you are done elevating as many contour lines by crossing as you can (or are 
comfortable with performing), click the Close button. 

14. In the View Filter Manager, select to view all layers. 

With all layers visible, your data should look something like this in the 3D View. 
(Don't worry if you screen image does not look exactly like the same.) 

  

Note that you can elevate some of the lingering contours by clicking one line at a 
time, elevating them based on a specified starting elevation, increment direction, 
and contour interval.  
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15. In the Plan View, zoom into the area specified above where you did not elevate 
lines. 

  

Notice how the elevated contour lines on the left side of the roadway correspond 
with the contours on the right side. You can use one of the elevated lines as a 
starting point for elevating the other lines. 

16. In the SO ribbon, select Data Prep > Elevate > Contour.  

  

17. In the Elevate Contour pane, do the following: 

a. In the Contour interval field, enter 2 for the vertical distance between each line. 

b. For the Increment direction, ensure the Up option is selected. 

c. Ensure that the Increment after each selection check box is checked so the 
elevation automatically increments for the next line after you pick a line. 

d. Click in the Current elevation field. Then, in the Plan View, pick the elevated 
line labeled 1 in the image below to specify its elevation.  
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382 is specified in the Current elevation field and the Contour line field is 
selected. 

e. Pick the first line in the unelevated series in the Plan View (2 in the image 
above).  

The line is elevated to 382. 

f. Click the next unelevated line in the series (3 in the image above).  

The contour interval value is added to the elevation of the last line picked and 
applied to the current line. 

g. Moving north along the left side of the circle only, continue picking the contour 
lines in the series to elevate them.  

  

After elevating all of the contour lines on the left side of the oval, you are ready 
to elevate the remaining contours on the right side of the oval. 

h. Click in the Current elevation field and select the last elevated line on the right 
side of the circle to establish a new starting elevation of 388. 
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i. Moving north along the right side of the circle, continue picking the contour 
lines in the series to elevate them.  

Optionally, after elevating several lines in a series this way using the Elevate 
Contour command, you could use the Elevate Contours by Crossing command 
to elevate the remaining lines in the series. 

j. When you are done, click Close. 

  

 

Step 9. Elevate other lines 

In this step you will elevate the roadway lines using a variety of objects that either 
intersect or lie near them, including the points that you created from spot elevation at 
the beginning of the tutorial. The elevations of the intersecting and nearby objects 
create and elevate vertical points of intersection (VPIs) along the elevated linestrings. 

1. In the SO ribbon, select Data Prep > Elevate > Lines. 



 

 

 www.spectrageospatial.com Page 36  
 

  

2. In the Elevate Lines pane, do the following: 

a. In the VPI Placement options group, select Point to use the elevations of points 
that lay on or near the lines you are elevating. 

b. In the Offset tolerance field, enter 0.5. 

c. Ensure nothing is selected in the Plan View. Then, click the Options button 
located next to the Points field and choose Select by Layer from the context 
menu to display the Select by Layer pane. 

d. Select Points to specify the nine points on the Points layer. Then click the Close 
button. 

  

e. Click the Options button located next to the Lines field and choose Select by 
Layer from the context menu. 

f. In the Select by Layer pane, select the P-CL layer to specify the five centerlines 
on the P-CL layer. Then click the Close button. 
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g. In the Elevate Lines command pane, click the Apply button.  

Four centerlines are elevated based on the elevation of the points. However, 
note that the fifth centerline was not elevated. This is because this centerline 
has no elevation data. To elevate this centerline, you will use the Intersecting 
line option. 

  

h. Select the Intersecting line option in the VPI Placement group.  

i. Ensure nothing is selected in the Plan View. Then, click in the Intersecting lines 
field and use Ctrl + click to select the two centerlines intersecting either side of 
the unelevated centerline as shown here. 
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j. Click in the Lines box and then select the unelevated centerline. 

k. Click Apply to elevate the remaining centerline. 

  

You are now ready to elevate the rest of the roading lines.  

l. Ensure nothing is selected in the Plan View. Then, click in the Intersecting lines 
field, click the Options button, and select the layers P-Grade 2C and P-Grade 
10C. 

m. Ensure nothing is selected in the Plan View. Then, click in the Lines field, click 
the Options button, and select the layers Paving and ROADS.  

  

n. Click Apply to elevate the the remaining roading lines 
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o. Click the Close button. 

Your data should now look similar to this. Do not be concerned if your's does not. 
What is important is that you understand the workflow. 

  

Most of the remaining unelevated lines represent building pads. You can elevate 
these using the elevation labels that lie inside the pad lines.  

In the SO ribbon, select Data Prep > Elevate > Pads. 

  

3. In the Elevate Pads pane, do the following: 

a. Verify the Selected lines option is selected so you elevate only the existing pad 
lines.  

The Offset line option enables you to create and elevate new pad lines that are 
offset from the original pad lines. Since you do not need to offset the selected 
lines, you do not need to make changes in the Settings group. 

b. Click the Select by Layer icon on the pane's toolbar to select the pad lines and 
their elevation labels by layer.  

c. In the Select by Layer pane, select the Finished floor elevation and Pads layers. 
Then click Close. 
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d. In the Elevate Pads pane, click the Apply button.  

Because there are labels for both finished floor elevations and base floor 
elevations, the Elevate Pads Prefix/Suffix Review dialog displays. 

  

e. Select FFE=[number], which is the finished floor elevation prefix, and click OK. 

Most of the pad lines should be elevated, but other pad lines did not encompass 
elevation labels, so they are not elevated. You will elevate these using the Set 
Line Elevation command. 

  

f. Click Close. 

4. In the SO ribbon, select Data Prep > Elevate > Set Line Elevation. 
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5. In the Set Line Elevation pane, do the following: 

a. Skip the Options group, and click in the Line field. 

b. In the Plan View, pick an unelevated pad line (1 in the figure below). 

The cursor automatically moves to the Elevation field. 

c. Pick the pad that it is paired with it (2 in the figure below), or its corresponding 
FFE elevation label. 

  

The unelevated pad is elevated to the same elevation as its paired pad. 

d. Repeat the previous steps until the rest of the pads are elevated. 

You can make your selections in the Plan View and then verify that the pad has 
been elevated in the 3D View. 

e. When you are done, click Close. 

Now, your unelevated data is getting sparse: 
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You could use any of the methods you have learned to elevate other lines you feel 
confident about. However, that is not necessary for this tutorial. 

 

Step 10. Check and fix your work 

Before you build a surface from your elevated objects, you should spot check their 
elevations in areas that you suspect may have errors. There are a variety of ways you 
can identify and check such areas. 

1. Click the 3D View tab. 

2. In the SO ribbon, select Home > View > 3D View > 3D View Settings. 

  

3. In the 3D View Settings pane, do the following: 

a. Click the  preset view button to see your elevated data from an 
orthographic side view (90° Vertical angle and 90° Azimuth). 

b. Move the Vertical Exaggeration slider to the right to increase the vertical 
spacing between elevations, and look for anomalies (for example, outlying 
elevated lines or a zero-elevation VPI on a linesting). 
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c. Make any required corrections as follows: 

 To correct the elevation of an outlying line, select it in the 3D View so you 
can find it in the Plan View. Then determine what the correct elevation 
should be, and edit the elevation using the Set Line Elevation command you 
used earlier.  

 To correct a zero-elevation VPI on a linesting, right-click the selected 
linestring and choose Edit from the context menu. In the Edit Linestring 
pane, select the Vertical tab and then click the Browse button located 
adjacent to the Current VPI field. In the Browse Vertical Information dialog, 
double-click the row with the incorrect elevation. Back in the pane, edit the 
value in the Elevation field. 

d. When you are done using the 3D View Settings to look for errors, set the 
Vertical Exaggeration Factor back to 1.00 and click the Close button. 

4. Press F11 to open the Properties pane. Then spot check elevations in either view by 
clicking lines and checking their elevations.  

Watch for the trends in ascending and descending elevations. 

5. To show line markings, in the Status bar (located at the bottom of the Survey Office 
window), select Toggle Line Marking. 
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Markers are symbols that distinguish between horizontal segment end points, arc 
mid points, VPIs, and the overall line's start and end points.  

 Filled circles denote linestring start points. 

 Filled triangles denote VPIs. 

 Smaller square dots denote "point on curve" mid points on arcs. 

 Smaller round dots denote segment end points. 

 Hollow circles denote linestring end points. 

Labels are annotations that indicate the elevation of vertical control points. 

6. To check linestrings that may have multiple elevations, in the SO ribbon, select 
Home > Data > Explore Object. Then pick a linestring in the Plan View. Move the 
cursor along the linestring to see the elevation at various locations. 

The elevation appears to the right of the cursor, as shown here. 
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7. If you discover missing or incorrect elevations, you can fix them using any of the 
following methods (based on the type of line): 

 CAD polyline or polyline - Edit the value in the Elevation field in the Properties 
pane. 

 CAD 3D polyline - Edit a constant elevation using the Set Line Elevation 
command or variable elevations using the CAD > Edit > Transform 
(Move/Rotate/Scale Objects) command. 

 Linesting - Edit VPIs using the method described in step 3c above. 

You can also display or hide markers and labels for horizontal and vertical values 
along lines in 2D views to make viewing, understanding, and editing them easier. In 
the Quick Launch tool bar, select the Project Settings. Then, in the Project Settings 
dialog, select View > Display Options > Marking and set Line marking to Show. 

8. To hide line markings, in the Status bar, select Toggle Line Markings. 

 

Step 11. Create a surface 

Once you are satisfied with the accuracy of your elevated data, you are ready to create a 
surface out of it.  

1. In the SO ribbon, select Surfaces > Create > Create Surface. 
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2. In the Create Surface pane, do the following: 

a. In the Name field, enter Design Surface. 

b. In the Surface Classification drop-down list, select Design.  

Classifications can be helpful when comparing one surface to another with a 
different classification in various reports. 

c. Click in the Members to form surface field. Then, in the 3D View, draw a 
window around just the elevated objects.  

  

d. Click OK to create the new surface. 

3. Use the View Filter Manager to filter the 3D View to show to only the newly 
created surface (deselect the other filter categories). 

  

4. Review the surface in the 3D View. 

5. To further simplify the view, right-click the surface and select Properties. Then 
experiment with hiding the wireframe, vertices, breaklines, and drapelines by 
setting their properties to No in the Show in Plan View and Show in 3D View 
sections. 
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This concludes the tutorial.  
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